Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 1.7.5rc5 build failure [with patch]
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-03-20 09:55:40


Talked to Nathan and he concurs with your proposed fix, so I'll add it only to v1.7 (leaving trunk alone)

Thanks Paul!

On Mar 19, 2014, at 9:40 PM, Paul Hargrove <phhargrove_at_[hidden]> wrote:

> Sorry to be the bearer of bad news...
>
> I configured on an SGI Altix UV with only "--enable-debug --enable-static --prefix=..."
>
> The configure script found the sn/xpmem.h header and threfore enabled btl:vader:
>
> --- MCA component btl:vader (m4 configuration macro)
> checking for MCA component btl:vader compile mode... static
> checking --with-xpmem value... simple ok (unspecified)
> checking --with-xpmem-libdir value... simple ok (unspecified)
> checking xpmem.h usability... no
> checking xpmem.h presence... no
> checking for xpmem.h... no
> checking sn/xpmem.h usability... yes
> checking sn/xpmem.h presence... yes
> checking for sn/xpmem.h... yes
> looking for library without search path
> checking for xpmem_make in -lxpmem... yes
> checking if MCA component btl:vader can compile... yes
>
> However, not only was btl:vader failing at runtime on the Altix when I last checked, but the version of the code in 1.7.5rc5 won't build:
>
> Making all in mca/btl/vader
> make[2]: Entering directory `/brashear/hargrove/OMPI/openmpi-1.7.5rc5-linux-x86_64-uv/BLD/ompi/mca/btl/vader'
> CC btl_vader_module.lo
> In file included from /usr/users/6/hargrove/SCRATCH/OMPI/openmpi-1.7.5rc5-linux-x86_64-uv/openmpi-1.7.5rc5/ompi/mca/btl/vader/btl_vader.h:76,
> from /usr/users/6/hargrove/SCRATCH/OMPI/openmpi-1.7.5rc5-linux-x86_64-uv/openmpi-1.7.5rc5/ompi/mca/btl/vader/btl_vader_module.c:26:
> /usr/users/6/hargrove/SCRATCH/OMPI/openmpi-1.7.5rc5-linux-x86_64-uv/openmpi-1.7.5rc5/ompi/mca/btl/vader/btl_vader_endpoint.h:28:19: error: xpmem.h: No such file or directory
>
> I think the safest/fastest fix is the following 1-line change to prevent locating sn/xpmem.h, which is Altix-specific:
>
> --- ompi/mca/btl/vader/configure.m4 (revision 31166)
> +++ ompi/mca/btl/vader/configure.m4 (working copy)
> @@ -23,7 +23,7 @@
> AC_ARG_WITH([xpmem],
> [AC_HELP_STRING([--with-xpmem(=DIR)],
> [Build with XPMEM kernel module support, searching for headers in DIR])])
> - OMPI_CHECK_WITHDIR([xpmem], [$with_xpmem], [include/xpmem.h include/sn/xpmem.h])
> + OMPI_CHECK_WITHDIR([xpmem], [$with_xpmem], [include/xpmem.h])
>
> AC_ARG_WITH([xpmem-libdir],
> [AC_HELP_STRING([--with-xpmem-libdir=DIR],
>
> This patch is intended for 1.7 only - lets leave the trunk as-is.
>
> -Paul
>
> --
> Paul H. Hargrove PHHargrove_at_[hidden]
> Future Technologies Group
> Computer and Data Sciences Department Tel: +1-510-495-2352
> Lawrence Berkeley National Laboratory Fax: +1-510-486-6900
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post: http://www.open-mpi.org/community/lists/devel/2014/03/14376.php