Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] orte-restart and PATH
From: Josh Hursey (jjhursey_at_[hidden])
Date: 2014-03-14 05:14:47

It looks like I did not add the prefix path to the binary name before
fork/exec in orte-restart.

There is a string variable that you can use to get the appropriate prefix:

It's the same one that Ralph mentioned that orterun uses.

If you add that on there then you should be ok. You might want to check the
app-files produces use the prefix as well when referencing opal-restart.

On Wed, Mar 12, 2014 at 11:34 AM, Ralph Castain <rhc_at_[hidden]> wrote:

> That's what the --enable-orterun-prefix-by-default configure option is for
> On Mar 12, 2014, at 9:28 AM, Adrian Reber <adrian_at_[hidden]> wrote:
> > I am using orte-restart without setting my PATH to my Open MPI
> > installation. I am running /full/path/to/orte-restart and orte-restart
> > tries to run mpirun to restart the process. This fails on my system
> > because I do not have any mpirun in my PATH. Is it expected for an Open
> > MPI installation to set up the PATH variable or should it work using the
> > absolute path to the binaries?
> >
> > Should I just set my PATH correctly and be done with it or should
> > orte-restart figure out the full path to its accompanying mpirun and
> > start mpirun with the full path?
> >
> > Adrian
> > _______________________________________________
> > devel mailing list
> > devel_at_[hidden]
> > Subscription:
> > Link to this post:
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription:
> Link to this post:

Joshua Hursey
Assistant Professor of Computer Science
University of Wisconsin-La Crosse