Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [EXTERNAL] 1.7.4rc: linux/ppc32/xlc-11.1 build failure
From: Paul Hargrove (phhargrove_at_[hidden])
Date: 2014-01-22 21:26:01


On Mon, Jan 20, 2014 at 12:24 PM, Barrett, Brian W <bwbarre_at_[hidden]>wrote:

> Ugh, this is a 32 bit RISC problem; we don't have a 64 bit atomic on a 32
> bit platform. People are supposed to check to see if there's 64 bit atomic
> support, but that clearly hasn't been happening. I've fixed this compile
> error, but there are still two places in the code base (bcol-basesmuma and
> coll-ml) that blindly use 64 bit atomics and I don't have time to fix
> those. I'll file a CMR for the core fix and bugs about the components, but
> I'm not hopeful people will fix them before the 1.7.4 release. Sigh.

I can confirm that a PPC32 builds of 1.7.4rc2r30361 w/ xlc (w/o fortran
support) now works for me.

-Paul

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
Computer and Data Sciences Department     Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900