Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] out-of-date item in README?
From: Paul Hargrove (phhargrove_at_[hidden])
Date: 2014-01-18 00:58:46


The README in trunk and v1.7 both read:

- ROMIO is not supported on OpenBSD. You will need to specify the
  --disable-io-romio flag to configure when building on OpenBSD.

However, I have no current problems building it:

$ ./INST/bin/ompi_info --parsable | grep -e :arch: -e romio
config:arch:x86_64-unknown-openbsd5.3
mca:io:romio:version:mca:2.0
mca:io:romio:version:api:2.0
mca:io:romio:version:component:1.7.4

This item in the README entered v1.5 in r25845 and was syned to trunk in
r26034.
The 02/23/2012 date for r25845 comes weeks AFTER I had resolved problems I
was having when testing v1.5 on OpenBSD (
http://www.open-mpi.org/community/lists/devel/2012/01/10300.php). So, I am
not sure why it was decided that ROMIO was broken on OpenBSD in 1.5.

-Paul

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
Computer and Data Sciences Department     Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900