Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] Compiler family probe broken [w/ patch]
From: Paul Hargrove (phhargrove_at_[hidden])
Date: 2014-01-17 21:38:33


I just noticed that I get unknown compiler family in all my builds:

checking for compiler familyid... 0
checking for compiler familyname... UNKNOWN

The following in config.log shows why:

configure:27774: checking for compiler familyid
configure:27804: xlc -o conftest -q64 -g
-I/home/hargrove/SCRATCH/OMPI/openmpi-1.7-latest-linux-ppc64-xlc-12.1/openmpi-1.7.4rc2r30303/ompi/include
  conftest.c >&5
"conftest.c", line 190.10: 1506-296 (S) #include file
"mpi_portable_platform.h" not found.
"conftest.c", line 197.23: 1506-045 (S) Undeclared identifier
PLATFORM_COMPILER_FAMILYID.
configure:27804: $? = 1
configure: program exited with status 1

Meanwhile:

$ tar tvfj openmpi-1.7.4rc2r30303.tar.bz2 | grep portable_platform
-rw-r--r-- mpiteam/projects 16055 2014-01-17 02:33
openmpi-1.7.4rc2r30303/opal/include/opal/opal_portable_platform.h

So, it appears the probe for compiler family didn't keep up with the change
in name and location of the portable_platform header (r29618).

Inspection of my tests on both v1.7 and trunk seems to show the same issue
in both.

The attached patch is an untested shot at fixing the problem.

-Paul

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
Computer and Data Sciences Department     Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900