Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Paul's testing summary
From: Paul Hargrove (phhargrove_at_[hidden])
Date: 2014-01-11 20:02:45


One addition:

7. netbsd6 static link failure (aio support resides in librt)
FIX PROPOSED
See thread beginning with
http://www.open-mpi.org/community/lists/devel/2014/01/13591.php
I have just now proposed a patch that resolves the problem for me.
This issue impacts both trunk and v1.7.

-Paul

On Sat, Jan 11, 2014 at 3:29 PM, Paul Hargrove <phhargrove_at_[hidden]> wrote:

> Updates:
>
> 1. opal/util/path.c
> RESOLVED
> My testing on both trunk and v1.7 passed on all my platforms.
> Marco's reports success (after applying the usual patches) with the trunk
> on Cygwin.
>
> 2. oshem_info reports oshmem:bindings:fort:yes unconditionally
> NO CHANGE (that I am aware of)
>
> 3. configure refuses btl:verbs on Solaris
> ISOLATED
> Jeff has traced this to some oshmem related configury.
> I have determined that configuring the trunk with --disable-oshmem DOES
> NOT work-around this issue.
> New thread:
> http://www.open-mpi.org/community/lists/devel/2014/01/13744.php
>
> 4. oob:tcp not using loopback interface for single-node runs
> NO CHANGE (that I am aware of)
>
> 5. pgi-8 and pgi-9 fail building mpi_f08
> WORK IN PROGRESS
> Jeff has provided more comprehensive fortran configure probes, but they
> didn't improve the situation.
> The "trunk is worse" problem was not what I had thought - it turns out to
> be triggered by --enable-debug.
>
> 6. netbsd-amd64 "make install" failure
> ISOLATED
> This is some issue between libtool and g95 mistakenly deciding the
> platform is a.out instead of elf.
> I can work-around by disabling fotran bindings.
>
>
> -Paul
>
>
> On Fri, Jan 10, 2014 at 8:39 PM, Paul Hargrove <phhargrove_at_[hidden]> wrote:
>
>> This is an attempt to summarize the status of the trunk and 1.7.4rc with
>> respect to my testing.
>>
>> There are 6 issues that to the best of my knowledge have not yet been
>> conclusively closed.
>> There might still be others buried in my sea of test results.
>>
>> 1. opal/util/path.c
>> See thread beginning with
>> http://www.open-mpi.org/community/lists/devel/2014/01/13597.php
>> Jeff and I have fixed this in trunk and Jeff CMRed for 1.7.4.
>> CMR was committed to v1.7 (changeset 30256) and thus just made the v1.7
>> tarball tonight.
>> Closed for trunk.
>> Closure for v1.7 just depends on me to test.
>>
>> 2. oshem_info reports oshmem:bindings:fort:yes unconditionally
>> See thread beginning with
>> http://www.open-mpi.org/community/lists/devel/2014/01/13616.php
>> and restarted in
>> http://www.open-mpi.org/community/lists/devel/2014/01/13677.php
>> Mike Dubman indicated he will fix this for trunk.
>> This does NOT apply to v1.7 (no oshmem).
>>
>> 3. configure refuses btl:verbs on Solaris
>> See thread beginning with
>> http://www.open-mpi.org/community/lists/devel/2014/01/13598.php
>> Jeff has indicated he will look into this one on trunk.
>> This does NOT apply to v1.7.
>>
>> 4. oob:tcp not using loopback interface for single-node runs
>> See thread beginning with
>> http://www.open-mpi.org/community/lists/devel/2014/01/13655.php
>> Ralph and I determined that the reported issue was due to the firewall on
>> my hosts blocking app-daemon connections.
>> Can work around via "-mca oob_tcp_if_include lo"
>> Ralph *may* see about a way to use loopback by default, but probably not
>> prior to 1.7.5
>> This issue is present both in trunk and v1.7
>>
>> 5. pgi-8 and pgi-9 fail building mpi_f08
>> See thread beginning with
>> http://www.open-mpi.org/community/lists/devel/2014/01/13651.php
>> Jeff is actively working to improve configure tests to disqualify these
>> compilers.
>> This issue as initially reported is present in v1.7
>> In trunk the same issue is present for pgi-9, but is worse (configure
>> "Cannot continue") for pgi-8
>>
>> 6. netbsd-amd64 "make install" failure
>> See thread beginning with
>> http://www.open-mpi.org/community/lists/devel/2013/12/13515.php
>> The issue does NOT appear on netbsd-i386 (reason unknown)
>> My attempts to autogen with the netbsd-supplied libtool turned up another
>> (now resolved) issue, but didn't fix this one.
>> Nobody has even commented on this issue.
>> This issue is present both in trunk and v1.7
>>
>> As far as I am concerned only #1 *must* be resolved for 1.7.4, and I am
>> going to do my part ASAP.
>> Items #2 and #3 are trunk-only.
>> Resolving #4 would be nice, but has a simple work around and is an issue
>> only on a "broken" host.
>> Resolving #5 would be great, but IMHO documenting these compilers as
>> unsupported for mpi_f08 would be sufficient.
>> Resolving #6 seems unlikely given the level of interest so far.
>>
>>
>> -Paul
>>
>> --
>> Paul H. Hargrove PHHargrove_at_[hidden]
>> Future Technologies Group
>> Computer and Data Sciences Department Tel: +1-510-495-2352
>> Lawrence Berkeley National Laboratory Fax: +1-510-486-6900
>>
>
>
>
> --
> Paul H. Hargrove PHHargrove_at_[hidden]
> Future Technologies Group
> Computer and Data Sciences Department Tel: +1-510-495-2352
> Lawrence Berkeley National Laboratory Fax: +1-510-486-6900
>

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
Computer and Data Sciences Department     Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900