Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 1.7.4rc2r30168 - PGI F08 failure
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-01-10 18:56:34


On Jan 10, 2014, at 6:45 PM, Paul Hargrove <phhargrove_at_[hidden]> wrote:

> Keep in mind that I have no specific reason to think pgi-10 should be accepted for building mpi_f08.
> My only observation was that it seemed to be rejected w/ less configure testing than was applied to accept 8.0 and 9.0.

Got it.

I see the reason, and it's weird.

PGI 8 and 9 support Fortran IGNORE TKR syntax, and it looks like PGI 10 does not. Truly odd.

Do you have the PGI 11 compiler? I thought someone said earlier that mpi_f08 worked with their PGI 11 compiler (which means that ignore TKR came back in PGI 11 -- maybe it was just a bug in your rev of PGI 10?).

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/