Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Openmpi 1.6.5 is freezing under GNU/Linux ia64
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-11-15 11:50:28


Hmm...well, that will make debug a tad more difficult. I've attached a patch that *should* stop the segfault. Given that behavior, though, it looks like the system isn't finding either rsh or ssh on your machine. Might be the root cause of the problem.

Ralph

On Nov 15, 2013, at 8:43 AM, Sylvestre Ledru <sylvestre_at_[hidden]> wrote:

> On 15/11/2013 17:37, Ralph Castain wrote:
>> Trying to replicate this, but I can't. I'm using the latest 1.6 tarball, not 1.6.5, so it is possible something was fixed - though I believe we have committed very few changes as that series is about to drop to "deprecated".
>>
>> First thing I encountered:
>>
>> configure: WARNING: unrecognized options: --disable-maintainer-mode, --enable-ltdl-convenience
>>
> the maintainer mode does matter.
>> So I removed those - no idea what they even do - but retained the rest of your configure options. I then used your cmd line, substituting "hostname" for "foo", and everything ran just fine on an ssh-based system. Here's my system info:
>>
>> Linux bend001 2.6.32-358.18.1.el6.x86_64 #1 SMP Wed Aug 28 17:19:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
>>
> Well, I am testing on ia64, not x86_64. This one is OK.
>> gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-3)
>>
>
> gcc (Debian 4.6.4-4) 4.6.4
>
> Sylvestre
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel