Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] ROMIO update breaks trunk
From: Thomas Naughton (naughtont_at_[hidden])
Date: 2013-11-14 16:05:44


Hi Ralph,

Does the version in AM_INIT_AUTOMAKE in configure.ac also need to be
increased? It currently shows 1.11.

Thanks,
--tjn

  _________________________________________________________________________
   Thomas Naughton naughtont_at_[hidden]
   Research Associate (865) 576-4184

On Thu, 14 Nov 2013, Ralph Castain wrote:

> Ha! Jeff points out that our web site says we are at AM 1.12.2 - yet our
> HACKING file says 1.11.1  Sadness
> I'll leave the romio update alone and update the HACKING file to avoid
> future confusion
>
>
> On Nov 14, 2013, at 12:41 PM, Ralph Castain <rhc_at_[hidden]> wrote:
>
> Just in case others are encountering this: the recent ROMIO
> update contains a line in its configure.ac that breaks the trunk
> for automake versions less than 1.12:
>
> "I've looked a bit around online for this, and the consensus generally seems
> to be that AM_PROG_AR should be added in libtool, not in every configure.ac
> script out there. It's especially problematic as AM_PROG_AR doesn't exist i
> n automake before 1.12, which means it breaks, among others, with the automa
> ke we use to build our distribution tarballs :-)
>
> See e.g. http://debbugs.gnu.org/cgi/bugreport.cgi?bug=11401 for a discussion
> ."
>
> I'm going to comment that line out in ompi/mca/io/romio/romio/configure.ac s
> o the trunk can build until someone figures out (a) if it is really needed,
> and (b) how to correctly add it
>
> Ralph
>
>
>
>
>
>