Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Openmpi 1.6.5 is freezing under GNU/Linux ia64
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-11-11 15:36:31


On Nov 4, 2013, at 12:14 PM, Sylvestre Ledru <sylvestre_at_[hidden]> wrote:

> FYI, I tried with OpenMPI 1.7.3 under ia64 and the build fails with:
> libtool: link: gcc -std=gnu99 -DNDEBUG -g -O2 -Wformat
> -Werror=format-security -finline-functions -fno-strict-aliasing -pthread
> -o .libs/orte-clean orte-clean.o -L/usr//lib
> ../../../orte/.libs/libopen-rte.so -lrt -lnsl -lutil -lm -lhwloc
> /usr/lib/ia64-linux-gnu/libltdl.so -pthread -Wl,-rpath
> -Wl,/usr/lib/openmpi/lib
> /usr/bin/ld: orte-clean.o: undefined reference to symbol
> 'opal_show_help_string'
> /home/sylvestre/openmpi-1.7.3/opal/.libs/libopen-pal.so.6: error adding
> symbols: DSO missing from command line

Sorry for the delay -- my INBOX management skills suck. :-(

No, this is not familiar. That symbol -- opal_show_help_string -- should definitely be in libopen-pal.so.

I do see -L/usr/lib in the command line, though, which is worrysome. I've seen problems when system-default library locations are manually listed in the command line (i.e., -L/usr/lib should probably *not* be listed in the command line; it can disrupt the order of search paths for libraries...?).

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/