On Tue, Nov 5, 2013 at 6:00 PM, Jeff Squyres (jsquyres)
> On Nov 5, 2013, at 2:54 PM, Paul Hargrove <phhargrove_at_[hidden]> wrote:
> > If this approach is to be adopted by other components (and perhaps other
> MPIs), then it would be important for the enumeration variable name to be
> derived in a UNIFORM way:
> > <framework>_<component>_SOMETHING
> > Without a fixed value for "SOMETHING" somebody will need to read sources
> (or documentation) to make the connection.
> This is a good point; we got a similar piece of feedback from the MPI
> tools group.
> How about naming the state variable "<framework>_<component>"? And then
> that will apply to all "<framework>_<component>*" pvars.
Hmm... not sure how that jives with "principle of least astonishment".
Other than that "_SOMETHING" == "" seems like a solution that totally
avoids the problems associated with words like "device" (which might imply
something about h/w architecture) or "instance" (with potential
implications regarding s/w architecture).
So, on balance: +0.9 (my other 0.1 goes to "_enum" for "principle of least
Paul H. Hargrove PHHargrove_at_[hidden]
Future Technologies Group
Computer and Data Sciences Department Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory Fax: +1-510-486-6900