Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Openmpi 1.6.5 is freezing under GNU/Linux ia64
From: Sylvestre Ledru (sylvestre_at_[hidden])
Date: 2013-11-04 12:14:28


On 02/10/2013 19:34, Jeff Squyres (jsquyres) wrote:
> On Sep 30, 2013, at 11:05 AM, Sylvestre Ledru <sylvestre_at_[hidden]> wrote:
>
>> Here are the options list:
>> configure: running /bin/bash './configure' CFLAGS="-DNDEBUG -g -O2
>> -Wformat -Werror=format-security -finline-functions -fno-strict-aliasing
>> -pthread" CPPFLAGS=" -I/usr//include -I/usr/include/infiniband
>> -I/usr/include/infiniband" FFLAGS="-g -O2" LDFLAGS=" -L/usr//lib"
>> --enable-shared --disable-static --prefix=/usr --with-mpi=open_mpi
>> --disable-aio --cache-file=/dev/null --srcdir=. --disable-option-checking
>
> Hmm -- I'm confused here; it's not possible that you're getting an assertion failure with this configure line, for two reasons:
>
> 1. The assert() in question will only be compiled in if you --enable-debug on the configure command line.
> 2. You supplied -DNDEBUG in CFLAGS, which means you've disabled all assert()s
sorry, that is automatically set by the Debian build system.

> Can you verify that this is the correct configure line that you used to generate that error? Or is something else going on?
I faced some issues building with these options. I will have to come
back on this.

>
>> Do you have an eta for the 1.8 ? (if I remember correctly, 1.7 is a
>> development release).
>
> 1.7 is a "feature" release. OMPI 1.odd.x series are stable and tested; they're just not as time-tested out in the real world as OMPI 1.even.x series.
>
> We're anticipating 1.8 will be out in early 2014.
>
FYI, I tried with OpenMPI 1.7.3 under ia64 and the build fails with:
libtool: link: gcc -std=gnu99 -DNDEBUG -g -O2 -Wformat
-Werror=format-security -finline-functions -fno-strict-aliasing -pthread
-o .libs/orte-clean orte-clean.o -L/usr//lib
../../../orte/.libs/libopen-rte.so -lrt -lnsl -lutil -lm -lhwloc
/usr/lib/ia64-linux-gnu/libltdl.so -pthread -Wl,-rpath
-Wl,/usr/lib/openmpi/lib
/usr/bin/ld: orte-clean.o: undefined reference to symbol
'opal_show_help_string'
/home/sylvestre/openmpi-1.7.3/opal/.libs/libopen-pal.so.6: error adding
symbols: DSO missing from command line

Sounds familar ?

Thanks
Sylvestre