Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Something missing in recent commit: OMPI_OSX_BUILTIN
From: Hjelm, Nathan T (hjelmn_at_[hidden])
Date: 2013-10-30 22:06:47


Found it. Not sure why this didn't come up during testing. Fixed in r29576.
________________________________________
From: devel [devel-bounces_at_[hidden]] on behalf of Hjelm, Nathan T [hjelmn_at_[hidden]]
Sent: Wednesday, October 30, 2013 8:03 PM
To: Open MPI Developers
Subject: Re: [OMPI devel] Something missing in recent commit: OMPI_OSX_BUILTIN

Ok, looks like I must have missed something. Will look into it now.

-Nathan
________________________________________
From: devel [devel-bounces_at_[hidden]] on behalf of Ralph Castain [rhc_at_[hidden]]
Sent: Wednesday, October 30, 2013 7:31 PM
To: Open MPI Developers
Subject: [OMPI devel] Something missing in recent commit: OMPI_OSX_BUILTIN

I'm seeing warnings on the trunk that something isn't defined when building on Linux:

In file included from ../../../opal/threads/mutex_unix.h:49,
                 from ../../../opal/threads/mutex.h:113,
                 from ../../../opal/class/opal_pointer_array.h:37,
                 from ../../../opal/mca/event/event.h:28,
                 from orterun.c:61:
../../../opal/include/opal/sys/atomic.h:166:29: warning: "OMPI_OSX_BUILTIN" is not defined
In file included from ../../opal/class/opal_list.h:75,
                 from ../../opal/mca/base/base.h:29,
                 from ../../ompi/mca/topo/topo.h:26,
                 from ompi_debugger_canary.c:17:
../../opal/include/opal/sys/atomic.h:166:29: warning: "OMPI_OSX_BUILTIN" is not defined
In file included from ../../opal/class/opal_list.h:75,
                 from ../../opal/mca/base/base.h:29,
                 from ompi_debuggers.c:49:
../../opal/include/opal/sys/atomic.h:166:29: warning: "OMPI_OSX_BUILTIN" is not defined

Searching the code base, the only place I can find OMPI_OSX_BUILTIN is:

./opal/include/opal/sys/atomic.h:166:#elif OPAL_ASSEMBLY_ARCH == OMPI_OSX_BUILTIN

Looks to me like something is missing!

_______________________________________________
devel mailing list
devel_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/devel