Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI devel] Something missing in recent commit: OMPI_OSX_BUILTIN
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-10-30 21:31:56


I'm seeing warnings on the trunk that something isn't defined when building on Linux:

In file included from ../../../opal/threads/mutex_unix.h:49,
                 from ../../../opal/threads/mutex.h:113,
                 from ../../../opal/class/opal_pointer_array.h:37,
                 from ../../../opal/mca/event/event.h:28,
                 from orterun.c:61:
../../../opal/include/opal/sys/atomic.h:166:29: warning: "OMPI_OSX_BUILTIN" is not defined
In file included from ../../opal/class/opal_list.h:75,
                 from ../../opal/mca/base/base.h:29,
                 from ../../ompi/mca/topo/topo.h:26,
                 from ompi_debugger_canary.c:17:
../../opal/include/opal/sys/atomic.h:166:29: warning: "OMPI_OSX_BUILTIN" is not defined
In file included from ../../opal/class/opal_list.h:75,
                 from ../../opal/mca/base/base.h:29,
                 from ompi_debuggers.c:49:
../../opal/include/opal/sys/atomic.h:166:29: warning: "OMPI_OSX_BUILTIN" is not defined

Searching the code base, the only place I can find OMPI_OSX_BUILTIN is:

./opal/include/opal/sys/atomic.h:166:#elif OPAL_ASSEMBLY_ARCH == OMPI_OSX_BUILTIN

Looks to me like something is missing!