Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] CM PML / OpenSHMEM
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-10-29 13:29:07


I think the issue that may have caused this was the need for a double modex if the MPI layer selected a PML that used an MTL, and then the user provided oshmem MCA params specifying they use the BTL-related SPML component. My guess is that the defaults wound up creating that situation, which then led to the clean abort.

Probably just a question of correctly setting defaults in the CM scenario.

On Oct 29, 2013, at 10:02 AM, Barrett, Brian W <bwbarre_at_[hidden]> wrote:

> Mellanox -
>
> It looks like someone fixed the segfault when calling start_pes() when the
> CM PML is in use. However, I'm not sure that a clean abort is much
> better. With the proc tags code (in both the trunk and v1.7), there's no
> reason that you can't initialize both the btls and mtls. This may require
> some additional coding, but I think it should be doable. I'm happy to
> help with advice / discuss implementation issues, but not supporting
> OpenSHMEM when the CM PML is in use is unacceptable and is, in my mind, a
> blocker for v1.7.
>
> Brian
>
> --
> Brian W. Barrett
> Scalable System Software Group
> Sandia National Laboratories
>
>
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel