Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] shmem vs. oshmem
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-10-25 17:32:01


On Oct 25, 2013, at 12:58 PM, Igor Ivanov <Igor.Ivanov_at_[hidden]> wrote:

>> - shmemcc / shmemfort / shmem_info / shmemrun
>> --> should these all be "oshmem*" ?
>>
>> - the examples are hello_shmem* and ring_shmem*
>> --> should these all be "*_oshmem*" ?
> These examples are not OpenSHMEM specific.
>>
>> - there are header files named shmem*
>> --> I'm guessing the names "shmem.h" and "shmem.fh" are mandated
> OpenSHMEM specification says

So ya, those names are standardized -- no problem.

But shouldn't we be branding everything else as oshmem? Even if the examples are not oshmem-specific.

We're shipping oshmem, not shmem, so why not call them oshmem examples [that also happen to be shmem examples] -- rather than shmem examples [that also happen to be oshmem examples]?

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/