Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] Problem with multiple identical entries in ~/.openmpi/mca-params.conf
From: Vallee, Geoffroy R. (valleegr_at_[hidden])
Date: 2013-09-20 17:49:41


Hi,

I found a very unexpected behavior with r29217:

% cat ~/.openmpi/mca-params.conf
#pml_base_verbose=0
pml_base_verbose=0

% mpicc -o helloworld helloworld.c

Then if i update the mca-params.conf to have two identical entries, i have segfaults:

% cat ~/.openmpi/mca-params.conf
pml_base_verbose=0
pml_base_verbose=0

% mpicc -o helloworld helloworld.c
[node0:23157] *** Process received signal ***
[node0:23157] Signal: Segmentation fault (11)
[node0:23157] Signal code: Address not mapped (1)
[node0:23157] Failing at address: 0x7f4812770100
^C

Note that the compilation hangs. Also note that i have the exact same problem when running an MPI application that was successfully compiled:

% cat ~/.openmpi/mca-params.conf
pml_base_verbose=0
#pml_base_verbose=0

% mpirun -np 2 ./helloworld
Hello, World (node0)
Hello, World (node0)

% mpirun -np 2 ./helloworld
Hello, World (node0)
Hello, World (node0)
[node0:23201] *** Process received signal ***
[node0:23201] Signal: Segmentation fault (11)
[node0:23201] Signal code: Address not mapped (1)
[node0:23201] Failing at address: 0x7f5a8f632c80
[node0:23202] *** Process received signal ***
[node0:23202] Signal: Segmentation fault (11)
[node0:23202] Signal code: Address not mapped (1)
[node0:23202] Failing at address: 0x7f1436605650
^C[node0:23199] *** Process received signal ***
[node0:23199] Signal: Segmentation fault (11)
[node0:23199] Signal code: Address not mapped (1)
[node0:23199] Failing at address: 0x7f9917dd55f0

The problem occurs during opal_finalize() and MCA tries to clean up some variables. Sorry i did not have the time to get a full trace.

Best regards,