Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [EXTERNAL] OpenSHMEM round 2
From: Barrett, Brian W (bwbarre_at_[hidden])
Date: 2013-08-10 22:21:30


On 8/6/13 10:30 AM, "Joshua Ladd" <joshual_at_[hidden]> wrote:

>Dear OMPI Community,
>
>Please find on Bitbucket the latest round of OSHMEM changes based on
>community feedback. Please git and test at your leisure.
>
>https://bitbucket.org/jladd_math/mlnx-oshmem.git

Josh -

In general, I think everything looks ok. However, the "right" thing
doesn't happen if the CM PML is used (at least, when using the Portals 4
MTL). When configured with:

  ./configure --enable-mca-no-build=pml-ob1,pml-bfo,pml-v,btl,bml,mpool

The build segfaults trying to run a SHMEM program:

mpirun -np 2 ./bcast
[shannon:90397] *** Process received signal ***
[shannon:90397] Signal: Segmentation fault (11)
[shannon:90397] Signal code: Address not mapped (1)
[shannon:90397] Failing at address: (nil)
[shannon:90398] *** Process received signal ***
[shannon:90398] Signal: Segmentation fault (11)
[shannon:90398] Signal code: Address not mapped (1)
[shannon:90398] Failing at address: (nil)
[shannon:90397] [ 0] /lib64/libpthread.so.0() [0x38b7a0f4a0]
[shannon:90397] *** End of error message ***
[shannon:90398] [ 0] /lib64/libpthread.so.0() [0x38b7a0f4a0]
[shannon:90398] *** End of error message ***
--------------------------------------------------------------------------
mpirun noticed that process rank 1 with PID 90398 on node shannon exited
on signal 11 (Segmentation fault).
--------------------------------------------------------------------------

Brian

--
  Brian W. Barrett
  Scalable System Software Group
  Sandia National Laboratories