Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] a bogus warning: undefined symbols not allowed in x86_64-pc-cygwin shared libraries
From: Vasiliy (testtest_2005_at_[hidden])
Date: 2013-07-09 07:01:08


I'll have to look into that. It looks like with all my humble patches
it should compile and pass the tests successfully even if compiled
with -march=native -mtune=native -Ofast+ optimization, and all the
perks enabled. That is, if the missing headers will be made available.

No, I haven't been contacted by Mellanox nor by any respectful
organization mentioned on the OMPI membership list to support Open MPI
under Cygwin 32/64-bit. Even if I have a degree in Physics, invested a
personal fortune in my Quantitative..., in my second-third degree
studies in Switzerland, and have 20+ years of work experience in the
IT field, quite recently with the Brutus cluster, who would be willing
to look for a new hire nowadays?

On Mon, Jul 8, 2013 at 9:09 PM, Jeff Squyres (jsquyres)
<jsquyres_at_[hidden]> wrote:
> This is not enough information to know what is going wrong with the debugger library -- all you pasted was a link failure with no surrounding context...
>
> Don't forget that we officially dropped Windows support in v1.7. Cygwin supposedly works, but we're not testing it, so I wouldn't be surprised if there's bit rot in there.
>
> Are you the same Vasily from Mellanox? If so, are you saying that Mellanox is working to support Open MPI under Cygwin?
>
>
>
> On Jul 8, 2013, at 3:00 PM, Vasiliy wrote:
>
>> I haven't checked that yet, however, from my experience, creating a
>> shared library manually from the same compiled objects never was a
>> problem at a later stage, it's usually because of Makefile's
>> inconsistent dependencies ordering:
>>
>> $ uname -srvmo
>> CYGWIN_NT-6.1 1.7.21(0.267/5/3) 2013-06-28 10:03 x86_64 Cygwin
>>
>> <code>
>> Making all in debuggers
>> make[2]: Entering directory
>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/ompi/debuggers'
>> CC libdebuggers_la-ompi_debuggers.lo
>> CCLD libdebuggers.la
>> CC ompi_debugger_canary.lo
>> CCLD libompi_debugger_canary.la
>> CC libompi_dbg_msgq_la-ompi_msgq_dll.lo
>> CC libompi_dbg_msgq_la-ompi_common_dll.lo
>> CCLD libompi_dbg_msgq.la
>> libtool: warning: undefined symbols not allowed in
>> x86_64-unknown-cygwin shared libraries
>> make[2]: Leaving directory
>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/ompi/debuggers'
>> </code>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel