Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] a bogus warning: undefined symbols not allowed in x86_64-pc-cygwin shared libraries
From: marco atzeri (marco.atzeri_at_[hidden])
Date: 2013-07-08 15:13:53


Il 7/8/2013 9:00 PM, Vasiliy ha scritto:
> I haven't checked that yet, however, from my experience, creating a
> shared library manually from the same compiled objects never was a
> problem at a later stage, it's usually because of Makefile's
> inconsistent dependencies ordering:
>
> $ uname -srvmo
> CYGWIN_NT-6.1 1.7.21(0.267/5/3) 2013-06-28 10:03 x86_64 Cygwin
>
> <code>
> Making all in debuggers
> make[2]: Entering directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/ompi/debuggers'
> CC libdebuggers_la-ompi_debuggers.lo
> CCLD libdebuggers.la
> CC ompi_debugger_canary.lo
> CCLD libompi_debugger_canary.la
> CC libompi_dbg_msgq_la-ompi_msgq_dll.lo
> CC libompi_dbg_msgq_la-ompi_common_dll.lo
> CCLD libompi_dbg_msgq.la
> libtool: warning: undefined symbols not allowed in
> x86_64-unknown-cygwin shared libraries
> make[2]: Leaving directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/ompi/debuggers'
> </code>

Hi Vasiliy
how do you called configure ?

I have not tested 1.9 on cygwin 64, but
1.7.1 cygwin64 package was built with

configure \
                 LDFLAGS="-Wl,--export-all-symbols -Wl,-no-undefined" \
                 --disable-mca-dso \
                 --disable-sysv-shmem \
                 --without-udapl \
                 --enable-cxx-exceptions \
                 --with-threads=posix \
                 --without-cs-fs \
                 --enable-heterogeneous \
                 --with-mpi-param_check=always \
                 --enable-contrib-no-build=vt,libompitrace \
 
--enable-mca-no-build=paffinity,installdirs-windows,timer-windows,shmem-sysv

Regards
Marco