Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] aclocal-1.14: error: ../../config/autogen_found_items.m4:274: file 'opal/mca/backtrace/configure.m4' does not exist
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-07-01 10:02:30


Sounds like you have a busted SVN checkout -- that file exists for me:

[10:02] jsquyres-mac:~/s/ompi3 ❯❯❯ svnversion .
28688
[10:02] jsquyres-mac:~/s/ompi3 ❯❯❯ svn info opal/mca/backtrace/configure.m4
Path: opal/mca/backtrace/configure.m4
Name: configure.m4
Working Copy Root Path: /Users/jsquyres/dev/svn/ompi3
URL: https://svn.open-mpi.org/svn/ompi/trunk/opal/mca/backtrace/configure.m4
Repository Root: https://svn.open-mpi.org/svn/ompi
Repository UUID: 63e3feb5-37d5-0310-a306-e8a459e722fe
Revision: 28688
Node Kind: file
Schedule: normal
Last Changed Author: rhc
Last Changed Rev: 23764
Last Changed Date: 2010-09-17 19:04:06 -0400 (Fri, 17 Sep 2010)
Text Last Updated: 2013-05-24 11:39:52 -0400 (Fri, 24 May 2013)
Checksum: a6d3741b6c9ab47daf2a6af6c812c148f91793a2

On Jul 1, 2013, at 9:58 AM, Vasiliy <testtest_2005_at_[hidden]>
 wrote:

> Hello,
>
> There is an error while configuring OpenMPI from the svn checkout with
> aclocal not being able to find 'opal/mca/backtrace/configure.m4',
> which, in fact, does exist there. What changes are needed to fix that?
>
> Note: it has stepped in the 'opal/libltdl' directory just before that error:
>
> *** GNU libltdl setup
> checking location of libltdl... internal copy
> configure: OMPI configuring in opal/libltdl
> configure: running /bin/sh
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl/configure'
> '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin'
> '--sbindir=/usr/sbin' '--libexecdir=/usr/lib' '--datadir=/usr/share'
> '--localstatedir=/var' '--sysconfdir=/etc' '--datarootdir=/usr/share'
> '--docdir=/usr/share/doc/openmpi' 'LDFLAGS=-Wl,--export-all-symbols
> -Wl,-no-undefined' '--disable-mca-dso' '--disable-sysv-shmem'
> '--without-udapl' '--enable-cxx-exceptions' '--with-threads=posix'
> '--without-cs-fs' '--enable-heterogeneous'
> '--with-mpi-param_check=always'
> '--enable-contrib-no-build=vt,libompitrace'
> '--enable-mca-no-build=paffinity,installdirs-windows,timer-windows,shmem-sysv'
> 'CC=gcc' 'CFLAGS=-ggdb -march=native -mtune=native -Ofast
> -fomit-frame-pointer -pipe
> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build=/usr/src/debug/openmpi-1.9.0-a1
> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0=/usr/src/debug/openmpi-1.9.0-a1'
> 'LIBS=' 'CPPFLAGS=' 'CXX=g++' 'CXXFLAGS=-ggdb -march=native
> -mtune=native -Ofast -fomit-frame-pointer -pipe
> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build=/usr/src/debug/openmpi-1.9.0-a1
> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0=/usr/src/debug/openmpi-1.9.0-a1'
> 'FC=gfortran' 'FCFLAGS=-ggdb -march=native -mtune=native -Ofast
> -fomit-frame-pointer -pipe
> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build=/usr/src/debug/openmpi-1.9.0-a1
> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0=/usr/src/debug/openmpi-1.9.0-a1'
> --enable-ltdl-convenience --disable-ltdl-install --enable-shared
> --disable-static --cache-file=/dev/null
> --srcdir=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl
> --disable-option-checking
> checking for a BSD-compatible install... /usr/bin/install -c
> <stripped>
>
> *** Final output
> checking that generated files are newer than configure... done
> <stripped>
>
> config.status: executing libtool commands
> Making all in config
> make[1]: Entering directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/config'
> make[1]: Nothing to be done for 'all'.
> make[1]: Leaving directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/config'
> Making all in contrib
> make[1]: Entering directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/contrib'
> make[1]: Nothing to be done for 'all'.
> make[1]: Leaving directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/contrib'
> Making all in opal
> make[1]: Entering directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal'
> Making all in include
> make[2]: Entering directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
> make all-am
> make[3]: Entering directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
> make[3]: Leaving directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
> make[2]: Leaving directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
> Making all in libltdl
> make[2]: Entering directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/libltdl'
> CDPATH="${ZSH_VERSION+.}:" && cd
> /usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl
> && /bin/sh /usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/config/missing
> aclocal-1.14 -I ../../config
> aclocal-1.14: error: ../../config/autogen_found_items.m4:274: file
> 'opal/mca/backtrace/configure.m4' does not exist
> Makefile:527: recipe for target
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl/aclocal.m4'
> failed
> make[2]: *** [/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl/aclocal.m4]
> Error 1
> make[2]: Leaving directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/libltdl'
> Makefile:2070: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory
> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal'
> Makefile:1578: recipe for target 'all-recursive' failed
> make: *** [all-recursive] Error 1
> *** ERROR: make failed
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/