Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] OpenMPI error with error codes. The proposed solution.
From: äÏÎÃÏ×, äÍÉÔÒÉÊ (dvdontsov_at_[hidden])
Date: 2013-03-27 05:06:43


Hi, Jeff

2013/3/27 Jeff Squyres (jsquyres) <jsquyres_at_[hidden]>
>
> Hmm. Can you cite where you see that in the spec? I see in MPI-3 p349, line 48:
> -- skipped --
> I see the definition of MPI_LASTUSEDCODE in MPI-3 p353 27-32, and it says that LASTUSEDCODE must be >= MPI_ERR_LASTCODE.

Yes, you are right I mean MPI-3 p353, lines 28-33.

>
>
> I applied a slightly modified version of your patch in https://svn.open-mpi.org/trac/ompi/changeset/28225. I don't know / doubt if this will make 1.7.0, but we can get it in 1.7.1.
>
It looks good, thank you.

WBR, Dmitry Dontsov