Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] v1.7.0rc7
From: Eugene Loh (eugene.loh_at_[hidden])
Date: 2013-02-26 16:36:40


On 02/23/13 14:45, Ralph Castain wrote:
> This release candidate is the last one we expect to have before release, so please test it. Can be downloaded from the usual place:
>
> http://www.open-mpi.org/software/ompi/v1.7/

I haven't looked at this very carefully yet. Maybe someone can confirm what I'm seeing? If I try to "mpirun `pwd`", the job should
fail (since I'm launching a directory rather than an executable). With v1.7, however, the return status is 0. (The error message
also suggests some confusion.)

My experiment is to run

     mpirun `pwd`
     echo status is $status

Here is v1.7:

     --------------------------------------------------------------------------
     Open MPI tried to fork a new process via the "execve" system call but
     failed. This is an unusual error because Open MPI checks many things
     before attempting to launch a child process. This error may be
     indicative of another problem on the target host. Your job will now
     abort.

       Local host: /workspace/eugene/v1.7-testing
       Application name: Permission denied
     --------------------------------------------------------------------------
     status is 0

Here is v1.6:

     --------------------------------------------------------------------------
     mpirun noticed that the job aborted, but has no info as to the process
     that caused that situation.
     --------------------------------------------------------------------------
     status is 1