Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] mpirun -host does not work from r27879 and forward on trunk
From: Rolf vandeVaart (rvandevaart_at_[hidden])
Date: 2013-01-31 14:16:46


Ralph and I talked off-list about the issue. He figured it and fixed it with changelist 27955.
See that changelist for the details.

>-----Original Message-----
>From: devel-bounces_at_[hidden] [mailto:devel-bounces_at_[hidden]]
>On Behalf Of Ralph Castain
>Sent: Thursday, January 31, 2013 11:51 AM
>To: Open MPI Developers
>Subject: Re: [OMPI devel] mpirun -host does not work from r27879 and
>forward on trunk
>
>Yes - no hostfile and no RM allocation, just -host.
>
>What is your setup?
>
>On Jan 31, 2013, at 8:44 AM, Rolf vandeVaart <rvandevaart_at_[hidden]>
>wrote:
>
>> Interesting. Yes, I was saying that the latest trunk does not work for me. I
>just retested the trunk also, and no luck.
>> Are you launching the MPI processes on remote nodes from the HNP?
>>
>>> -----Original Message-----
>>> From: devel-bounces_at_[hidden] [mailto:devel-bounces_at_open-
>mpi.org]
>>> On Behalf Of Ralph Castain
>>> Sent: Thursday, January 31, 2013 11:40 AM
>>> To: Open MPI Developers
>>> Subject: Re: [OMPI devel] mpirun -host does not work from r27879 and
>>> forward on trunk
>>>
>>> FWIW: I just tried it on the trunk head and it worked fine
>>>
>>> On Jan 31, 2013, at 8:20 AM, Ralph Castain <rhc_at_[hidden]> wrote:
>>>
>>>> Ummm...that was fixed a long time ago. You might try a later version.
>>>>
>>>> Or are you saying the head of the trunk doesn't work too?
>>>>
>>>> On Jan 31, 2013, at 7:31 AM, Rolf vandeVaart
>>>> <rvandevaart_at_[hidden]>
>>> wrote:
>>>>
>>>>> I have stumbled into a problem with the -host argument. This
>>>>> problem
>>> appears to be introduced with changeset r27879 on 1/19/2013 by rhc.
>>>>>
>>>>> With r27877, things work:
>>>>> [rolf_at_node]$ which mpirun
>>>>> /home/rolf/ompi-trunk-r27877/64/bin/mpirun
>>>>> [rolf_at_node]$ mpirun -np 2 -host c0-0,c0-3 hostname
>>>>> c0-3
>>>>> c0-0
>>>>>
>>>>> With r27879, things are broken:
>>>>> [rolf_at_node]$ setenv PATH
>>>>> /home/rolf/ompi-trunk-r27879/64/bin:${PATH}
>>>>> [rolf_at_node]$ mpirun -np 2 -host c0-0,c0-3 hostname
>>>>> -------------------------------------------------------------------
>>>>> --
>>>>> ----- All nodes which are allocated for this job are already filled.
>>>>> -------------------------------------------------------------------
>>>>> --
>>>>> -----
>>>>> [rolf_at_Fermi-Cluster nv]$
>>>>>
>>>>> Note: Could not compile r27878 so did not test that.
>>>>>
>>>>> I can only run processes on the same node as mpirun.
>>>>>
>>>>> -------------------------------------------------------------------
>>>>> --
>>>>> -------------- This email message is for the sole use of the
>>>>> intended
>>>>> recipient(s) and may contain confidential information. Any
>>>>> unauthorized review, use, disclosure or distribution is prohibited.
>>>>> If you are not the intended recipient, please contact the sender by
>>>>> reply email and destroy all copies of the original message.
>>>>> -------------------------------------------------------------------
>>>>> --
>>>>> --------------
>>>>>
>>>>> _______________________________________________
>>>>> devel mailing list
>>>>> devel_at_[hidden]
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>>
>>>
>>>
>>> _______________________________________________
>>> devel mailing list
>>> devel_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
>_______________________________________________
>devel mailing list
>devel_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/devel