Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Open MPI (not quite) on Cray XC30
From: Jure Pečar (pegasus_at_[hidden])
Date: 2013-01-30 12:31:09


On Wed, 30 Jan 2013 08:48:02 -0700
Nathan Hjelm <hjelmn_at_[hidden]> wrote:

> Try configuring with --with-platform=contrib/platform/lanl/cray_xe6/optimized-nopanasas . That might work. If it doesn't try the optimized-lustre file from the same directory in trunk.
>

I used optimized-common. That fails with:

mca/btl/openib/.libs/libmca_btl_openib.a(btl_openib_xrc.o):(.data+0x0): multiple definition of `ib_address_t_class'
mca/common/ofacm/.libs/libmca_common_ofacm_noinst.a(common_ofacm_xoob.o):(.data+0x0): first defined here

So I tried adding --enable-mca-static=btl:ugni,btl:self --enable-contrib-no-build=libnbc,vt to configure and got this:
 CCLD ompi_info
../../../ompi/.libs/libmpi.so: undefined reference to `mca_common_sm_fini'
../../../ompi/.libs/libmpi.so: undefined reference to `ibv_free_device_list_compat'
../../../ompi/.libs/libmpi.so: undefined reference to `ibv_get_device_list_compat'
../../../ompi/.libs/libmpi.so: undefined reference to `ompi_common_ugni_ep_destroy'
../../../ompi/.libs/libmpi.so: undefined reference to `mca_common_sm_init'
../../../ompi/.libs/libmpi.so: undefined reference to `ompi_common_ugni_module'
../../../ompi/.libs/libmpi.so: undefined reference to `ompi_common_ugni_endpoint_return'
../../../ompi/.libs/libmpi.so: undefined reference to `ompi_common_ugni_fini'
../../../ompi/.libs/libmpi.so: undefined reference to `ompi_common_ugni_ep_create'
../../../ompi/.libs/libmpi.so: undefined reference to `ompi_common_ugni_init'
../../../ompi/.libs/libmpi.so: undefined reference to `ompi_common_ugni_endpoint_for_proc'

Help?

-- 
Jure Pečar
http://jure.pecar.org
http://f5j.eu