Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [EXTERNAL] Open MPI Configure Script
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-01-28 14:07:13


I don't see anything in the config script that checks for gcc - you might take a look at it to check. It's in config/orte_check_tm.m4 on our developer's trunk

On Jan 28, 2013, at 10:54 AM, David Beer <dbeer_at_[hidden]> wrote:

>
> On Mon, Jan 28, 2013 at 10:54 AM, Barrett, Brian W <bwbarre_at_[hidden]> wrote:
>
> We assume that we can link lib torque into a C application (if this is a problem for you, it's a huge deal breaker for us, since OMPI is a C library). What does config.log say when checking for tm_init?
>
> Brian
>
>
> Brian,
>
> libtorque can still be linked in to C applications. In testing with a simple C program, we did have to add
>
> void *__gxx_personality_v0;
>
> to the C program. Here is the error reported by the configure script:
>
> checking for pbs-config... /usr/local/bin/pbs-config
> checking tm.h usability... yes
> checking tm.h presence... yes
> checking for tm.h... yes
> checking for tm_finalize... no
> looking for header without includes
> checking tm.h usability... yes
> checking tm.h presence... yes
> checking for tm.h... yes
> looking for library without search path
> checking for tm_init in -lpbs... no
> looking for library in lib
> checking for tm_init in -lpbs... no
> looking for library in lib64
> checking for tm_init in -lpbs... no
> looking for library without search path
> checking for tm_init in -ltorque... no
> looking for library in lib
> checking for tm_init in -ltorque... no
> looking for library in lib64
> checking for tm_init in -ltorque... no
> configure: error: TM support requested but not found. Aborting
>
> Oddly enough, if you have already configured with an older version of TORQUE, you can build open-mpi with TORQUE 4.2 installed, so it can find the function definitions when compiling, its just for some reason it doesn't find them in the configure script. This is why I think that something in the configure script is assuming that libtorque was compiled with gcc.
>
> David
>
> --
> Brian W. Barrett
> Scalable System Software Group
> Sandia National Laboratories
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
>
> --
> David Beer | Senior Software Engineer
> Adaptive Computing
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel