Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 1.6.4rc1 has been posted
From: Paul Hargrove (phhargrove_at_[hidden])
Date: 2013-01-17 21:14:25


On Thu, Jan 17, 2013 at 5:36 PM, Paul Hargrove <phhargrove_at_[hidden]> wrote:

> On Thu, Jan 17, 2013 at 4:37 PM, Paul Hargrove <phhargrove_at_[hidden]> wrote:
> [snip]
>
>> I just now ran tests on OpenBSD-5.2/i386 and OpenBSD-5.2/amd64, using
>> Clang-3.1.
>> Unfortunately, there is a mass of linker error building libmpi_cxx.la(on both systems)
>> I am trying again with --disable-mpi-cxx and will report my results later.
>>
> [snip]
>
> Using --disable-mpi-cxx I still have linker problems, now from the C++
> lib(s) in VT.
> So, I've just gone ahead and tried CC=clang CXX=g++, which worked fine.
>
> Given the VT failure, I am guessing that the issue is clang++, rather than
> something in OMPI "proper".
> OR, perhaps is because my Clang install pre-dates my upgrade from
> OpenBSD-5.1 to 5.2.
> I'll re-install Clang and post new results when I have them.
>

Re-installing clang made no difference.
This failure (clang++-3,1 on OpenBSD-5.2) doesn't bother me one iota.
However, if somebody wants to look into it, let me know and I can provide
the details (on- or off-list as determined by the requester).

-Paul

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
Computer and Data Sciences Department     Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900