Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] Build open MPI
From: Ding, Boxiong (Boxiong.Ding_at_[hidden])
Date: 2013-01-09 20:37:50


Hi,

I am trying to build the code that Ralph has put here: https://boxding@bitbucket.org/rhc/hdmon, but failed. It is a modified open MPI code. Can someone help?

[root_at_aesaroyp1d1c hdmon]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.1 (Santiago)

I have manually installed m4/autoconf/automake/libtool on my local directory and the versions match those specified in HACKING.
[root_at_aesaroyp1d1c lib]# pwd
/root/local/lib
[root_at_aesaroyp1d1c lib]# ls
autoconf-2.68 automake-1.11.1 libtool-2.2.8 m4-1.4.13

[root_at_aesaroyp1d1c lib]# which m4
/root/local/lib/m4-1.4.13/bin/m4
[root_at_aesaroyp1d1c lib]# which autoconf
/root/local/lib/autoconf-2.68/bin/autoconf
[root_at_aesaroyp1d1c lib]# which automake
/root/local/lib/automake-1.11.1/bin/automake
[root_at_aesaroyp1d1c lib]# which libtool
/root/local/lib/libtool-2.2.8/bin/libtool

When I run autogen.pl I got the following error:
....
6. Processing autogen.subdirs directories

=== Processing subdir: /root/workspace/hdmon/opal/mca/event/libevent2019/libevent
--- Found autogen.sh; running...
Running: ./autogen.sh
autoreconf: Entering directory `.'
autoreconf: configure.in: not using Gettext
autoreconf: running: aclocal -I .. --force -I m4
autoreconf: configure.in: tracing
autoreconf: configure.in: not using Libtool
autoreconf: running: /root/local/lib/autoconf-2.68/bin/autoconf --include=.. --force
configure.in:146: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /root/local/lib/autoconf-2.68/bin/autoconf failed with exit status: 1
Command failed: ./autogen.sh

Thanks,
Boxiong