Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] Error compiling
From: R C (recifx_at_[hidden])
Date: 2012-12-23 11:37:49


I updated to r27716, reran autogen.pl and configure, but on running 'make
all' I get this error:

Making all in tools/orte-clean
make[2]: Entering directory
`/home/rc/Downloads/ompi/objd/orte/tools/orte-clean'
  CC orte-clean.o
make[2]: *** No rule to make target `../../../orte/libopen-pal.la', needed
by `orte-clean'. Stop.
make[2]: Leaving directory
`/home/rc/Downloads/ompi/objd/orte/tools/orte-clean'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rc/Downloads/ompi/objd/orte'
make: *** [all-recursive] Error 1

Thanks for looking into this.

On Sun, Dec 23, 2012 at 10:56 AM, Ralph Castain <rhc_at_[hidden]> wrote:

> Should be fixed with r27716. We had reorganized the linking a little while
> ago, and the person who did it thought that the indirect references would
> be resolved - i.e., that linking against liborte would automatically
> resolve any calls to functions in libopal since liborte is linked against
> libopal. Sadly, this wasn't true for the Mac, and it looks like it isn't
> true for Ubuntu either.
>
> Anyway, I resolved it by simply adding libopal to the list of libs for
> those tools. Let me know if it fixes this for you.
>
>
> On Dec 23, 2012, at 7:39 AM, R C <recifx_at_[hidden]> wrote:
>
> I am trying to compile the development version of openmpi obtained through
> svn yesterday, on a AMD64 computer running Ubuntu 12.10 (gcc 4.7.2)
> with valgrind-3.8.1 installed in /usr/local
>
> After ./autogen.pl. I ran configure:
> ../configure FC=gfortran --with-mpi-f90-size=medium
> --with-f90-max-array-dim=6 --with-valgrind=/usr/local
>
> however 'make all' exited with the error:
>
> make[2]: Entering directory
> `/home/rc/Downloads/ompi/objd/orte/tools/orte-clean'
> CC orte-clean.o
> CCLD orte-clean
> /usr/bin/ld: orte-clean.o: undefined reference to symbol
> 'opal_show_help_string'
> /usr/bin/ld: note: 'opal_show_help_string' is defined in DSO
> /home/rc/Downloads/ompi/objd/opal/.libs/libopen-pal.so.0 so try adding it
> to the linker command line
> /home/rc/Downloads/ompi/objd/opal/.libs/libopen-pal.so.0: could not read
> symbols: Invalid operation
> collect2: error: ld returned 1 exit status
> make[2]: *** [orte-clean] Error 1
> make[2]: Leaving directory
> `/home/rc/Downloads/ompi/objd/orte/tools/orte-clean'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/rc/Downloads/ompi/objd/orte'
> make: *** [all-recursive] Error 1
>
> I checked libopen-pal.so.0 using nm.
>
> Any suggestions to get the compilation working would be appreciated.
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>