Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] opempi with gcc4.8 on Mac OSX10.7
From: surendra_at_[hidden]
Date: 2012-12-14 22:50:28


Thanks Paul. I asked Xcode to install command line tools which gave a different version of gcc that had no problems install openmpi1.6.3

Surendra

On Dec 14, 2012, at 6:51 PM, Paul Hargrove wrote:

> Surendra,
>
> There is no "release" of gcc-4.8 yet, and my experience (not Open MPI related) with recent snapshots has encountered many bugs still to be fixed before any release. Even if you could build Open MPI with gcc-4.8, I would not (at this time) trust it with any "production" jobs.
>
> Looking at the config.log you attached, it looks like your installation of gcc is unable to run the "as" assembler, which probably means you don't have Apple Xcode installed (which is the preferred source of the assembler and linker on Mac OSX). So, I doubt that you can even build a "Hello, World!" C program with your gcc installation - have you tried?
>
> -Paul
>
>
> On Fri, Dec 14, 2012 at 6:45 PM, <surendra_at_[hidden]> wrote:
> Hi,
>
> Has openmpi1.6.3 been tested with gcc4.8?
>
> Attached is my config.log
>
> thanks,
> Surendra
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
>
> --
> Paul H. Hargrove PHHargrove_at_[hidden]
> Future Technologies Group
> Computer and Data Sciences Department Tel: +1-510-495-2352
> Lawrence Berkeley National Laboratory Fax: +1-510-486-6900
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel