Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Open-mpi in Fedora 5
From: Sandra Guija (sguija_at_[hidden])
Date: 2012-10-09 03:04:00


Hi Jeff,Mi error is when either I run a mpi program on the remote host or I run on the local host and include the remote host.openmpi only works where the it was installed, local.Plan B is to install openmpi on the remote host and try to run it , but I'm getting discourage.I am using 1.2.9 and I found the same error in this post:http://www.open-mpi.org/community/lists/users/2008/07/6034.phpMy error looks exactly as the one describe above, but my fist line is: bash: orted command not foundIf does not work, Plan C is to try what the post recommended version 1.3, but not sure.Any input is appreciatedThanks againSandra Guija

> From: jsquyres_at_[hidden]
> Date: Mon, 8 Oct 2012 20:19:14 -0400
> To: devel_at_[hidden]
> Subject: Re: [OMPI devel] Open-mpi in Fedora 5
>
> I'm not sure I understand -- you said you are able to run on the master, but then you said you get an error message when you run on the master.
>
> Please see the help page I mentioned (http://www.open-mpi.org/community/help/) for a list of information that we need to be able to help you.
>
> If you're getting a message about permission denied for /home/openmpi/bin/orted, you should check the permissions on that file; it needs to be executable. If it isn't executable, then you need to check how you installed Open MPI -- Open MPI's installer should have marked it as executable during the installation process.
>
>
> On Oct 7, 2012, at 12:17 PM, Sandra Guija wrote:
>
> > Hi Jeff,
> > I shared the openpi libraries through NFS. I am able to ssh with out password, using id_rsa and eval`ssh-agent`
> > I got mpirun run the thee test you mentioned below. The test succeed only if I run on the master.
> > I am running with the mpiu user with same UID,
> > But I am not able to run the mpirun on the remote host. The message I got when I run on the remote host is below.
> > I have check the permission on the .ssh and libraries, and I included the PATH in .bashrc and .bash_profile, I tried modify /etc/profile but not sure how to do it.
> > I attached the screen shoot when I run on the master.
> >
> > shell$ mpirun--debig-daemons --host tango1 hello_world
> > -bash:/home/openmpi/bin/mpirun: Permission denied
> >
> >
> > Sandra Guija
> >
> > > From: jsquyres_at_[hidden]
> > > Date: Fri, 5 Oct 2012 16:55:44 -0400
> > > To: devel_at_[hidden]
> > > Subject: Re: [OMPI devel] Open-mpi in Fedora 5
> > >
> > > On Oct 5, 2012, at 3:40 PM, Sandra Guija wrote:
> > >
> > > > I decided to use an environment with Fedora 5 and gcc 4.1.0.
> > > > I tried to installed 1.6.2 and it failed, then tried 1.4.5 and it failed, then 1.2.9 and I did not get any error.
> > >
> > > I know that we are sometimes a little slow to answer user emails, but you need to give us more than a few hours to answer before re-posting your mails. :-)
> > >
> > > If you want to see if there are easy fixes to why 1.4.x and/or 1.6.x fail to compile, see this page: http://www.open-mpi.org/community/help/ Send all the info listed on that page.
> > >
> > > > how I can check if the installation works, prior to configure the cluster
> > >
> > > See:
> > >
> > > http://www.open-mpi.org/community/lists/users/2012/03/18846.php
> > >
> > > We say something quite similar in the (1.6.x) README file:
> > >
> > > When verifying a new Open MPI installation, we recommend running three
> > > tests:
> > >
> > > -----
> > > 1. Use "mpirun" to launch a non-MPI program (e.g., hostname or uptime)
> > > across multiple nodes.
> > >
> > > 2. Use "mpirun" to launch a trivial MPI program that does no MPI
> > > communication (e.g., the hello_c program in the examples/ directory
> > > in the Open MPI distribution).
> > >
> > > 3. Use "mpirun" to launch a trivial MPI program that sends and
> > > receives a few MPI messages (e.g., the ring_c program in the
> > > examples/ directory in the Open MPI distribution).
> > >
> > > If you can run all three of these tests successfully, that is a good
> > > indication that Open MPI built and installed properly.
> > > -----
> > >
> > > > Also, it will be ok if I copy the openmpi-1.2.9 directory to the other nodes? The installation took like almost 3 hours.
> > >
> > > Wow; configuration / compilation of Open MPI took *3 hours*? I'm guessing you have very old / low-power processors, or very slow network filesystem access...?
> > >
> > > See this FAQ information on where to install OMPI:
> > >
> > > http://www.open-mpi.org/faq/?category=building#where-to-install
> > >
> > > > I sent the "ccIVTymL.out" file to the forum but my mail is waiting for moderator approval.
> > >
> > > It likely won't be approved. Send a smaller attachment, please, such as a compressed text file (see the support page, above). :-)
> > >
> > > --
> > > Jeff Squyres
> > > jsquyres_at_[hidden]
> > > For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
> > >
> > >
> > > _______________________________________________
> > > devel mailing list
> > > devel_at_[hidden]
> > > http://www.open-mpi.org/mailman/listinfo.cgi/devel
> > <openmpi_on_master.PNG>_______________________________________________
> > devel mailing list
> > devel_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel