Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] Open-mpi in Fedora 5
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-10-05 16:55:44


On Oct 5, 2012, at 3:40 PM, Sandra Guija wrote:

> I decided to use an environment with Fedora 5 and gcc 4.1.0.
> I tried to installed 1.6.2 and it failed, then tried 1.4.5 and it failed, then 1.2.9 and I did not get any error.

I know that we are sometimes a little slow to answer user emails, but you need to give us more than a few hours to answer before re-posting your mails. :-)

If you want to see if there are easy fixes to why 1.4.x and/or 1.6.x fail to compile, see this page: http://www.open-mpi.org/community/help/ Send all the info listed on that page.

> how I can check if the installation works, prior to configure the cluster

See:

    http://www.open-mpi.org/community/lists/users/2012/03/18846.php

We say something quite similar in the (1.6.x) README file:

When verifying a new Open MPI installation, we recommend running three
tests:

-----
1. Use "mpirun" to launch a non-MPI program (e.g., hostname or uptime)
   across multiple nodes.

2. Use "mpirun" to launch a trivial MPI program that does no MPI
   communication (e.g., the hello_c program in the examples/ directory
   in the Open MPI distribution).

3. Use "mpirun" to launch a trivial MPI program that sends and
   receives a few MPI messages (e.g., the ring_c program in the
   examples/ directory in the Open MPI distribution).

If you can run all three of these tests successfully, that is a good
indication that Open MPI built and installed properly.
-----

> Also, it will be ok if I copy the openmpi-1.2.9 directory to the other nodes? The installation took like almost 3 hours.

Wow; configuration / compilation of Open MPI took *3 hours*? I'm guessing you have very old / low-power processors, or very slow network filesystem access...?

See this FAQ information on where to install OMPI:

    http://www.open-mpi.org/faq/?category=building#where-to-install

> I sent the "ccIVTymL.out" file to the forum but my mail is waiting for moderator approval.

It likely won't be approved. Send a smaller attachment, please, such as a compressed text file (see the support page, above). :-)

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/