Open MPI already have a similar function in the communicator part, function that is not exposed to the upper layer. I think that using the code in ompi_comm_compare (the second part that compare groups) is sound proof. Moreover, if now we have an ompi_group_compare function you should use it in the ompi_comm_compare to ease the readability of the code.
On Mar 8, 2012, at 16:57 , jjhursey_at_[hidden] wrote:
> Author: jjhursey
> Date: 2012-03-08 16:57:45 EST (Thu, 08 Mar 2012)
> New Revision: 26118
> URL: https://svn.open-mpi.org/trac/ompi/changeset/26118
> Abstract MPI_Group_compare to an OMPI function for internal use (point the MPI interface to the internal function).