Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] 1.5 supported systems
From: Paul H. Hargrove (PHHargrove_at_[hidden])
Date: 2012-02-22 21:57:55


I have NOT been running Intel's compilers on Macs, only on Linux.
I *tried* PGI's compilers on MacOS, but that was a flop.
I have used Clang (comes w/ XCode 4.2) on MacOS, and that works for me
but is not extensively tested.

-Paul

On 2/22/2012 6:13 PM, Larry Baker wrote:
> Paul,
>
> Haven't you been running Intel compilers on OS X?
>
> Also, do we have specifics about which gcc's on Mac OS X? I have (OS
> X 10.5.8):
>
>> savaii:~ baker$ ls -l /usr/bin/gcc*
>> lrwxr-xr-x 1 root wheel 7 Oct 2 2009 /usr/bin/gcc -> gcc-4.0
>> -r-xr-xr-x 1 root wheel 258368 Feb 19 2008 /usr/bin/gcc-3.3
>> -rwxr-xr-x 1 root wheel 93088 Feb 5 2009 /usr/bin/gcc-4.0
>> -rwxr-xr-x 1 root wheel 105680 Apr 27 2009 /usr/bin/gcc-4.2
>
>> savaii:~ baker$ ls -l /usr/bin/cc*
>> lrwxr-xr-x 1 root wheel 7 Oct 2 2009 /usr/bin/cc -> gcc-4.0
>
>> savaii:~ baker$ ls /Developer/usr/llvm-gcc-4.2/bin/*cc*
>> /Developer/usr/llvm-gcc-4.2/bin/i686-apple-darwin9-llvm-gcc-4.2
>> /Developer/usr/llvm-gcc-4.2/bin/llvm-gcc-4.2
>> /Developer/usr/llvm-gcc-4.2/bin/powerpc-apple-darwin9-llvm-gcc-4.2
>
> Larry Baker
> US Geological Survey
> 650-329-5608
> baker_at_[hidden] <mailto:baker_at_[hidden]>
>
> On 22 Feb 2012, at 5:55 PM, Paul H. Hargrove wrote:
>
>> Folks at Oracle should decide, but I suspect "Solaris 10" should be
>> updated to "Solaris 10 and 11", or just "11".
>>
>> -Paul
>>
>> On 2/22/2012 2:44 PM, Jeffrey Squyres wrote:
>>> Please verify this list of supported systems for the v1.5.5 release:
>>>
>>> - The run-time systems that are currently supported are:
>>> - rsh / ssh
>>> - LoadLeveler
>>> - PBS Pro, Open PBS, Torque
>>> - Platform LSF (v7.0.2 and later)
>>> - SLURM
>>> - Cray XT-3, XT-4, and XT-5
>>> - Oracle Grid Engine (OGE) 6.1, 6.2 and open source Grid Engine
>>> - Microsoft Windows CCP (Microsoft Windows server 2003 and 2008)
>>>
>>> - Systems that have been tested are:
>>> - Linux (various flavors/distros), 32 bit, with gcc, and Oracle
>>> Solaris Studio 12
>>> - Linux (various flavors/distros), 64 bit (x86), with gcc, Absoft,
>>> Intel, Portland, and Oracle Solaris Studio 12 compilers (*)
>>> - OS X (10.5, 10.6, 10.7), 32 and 64 bit (x86_64), with gcc and
>>> Absoft compilers (*)
>>> - Oracle Solaris 10, 32 and 64 bit (SPARC, i386, x86_64), with
>>> Oracle Solaris Studio 12
>>>
>>> (*) Be sure to read the Compiler Notes, below.
>>>
>>> - Other systems have been lightly (but not fully tested):
>>> - Other 64 bit platforms (e.g., Linux on PPC64)
>>> - Microsoft Windows CCP (Microsoft Windows server 2003 and 2008);
>>> see the README.WINDOWS file.
>>>
>>
>> --
>> Paul H. Hargrove PHHargrove_at_[hidden] <mailto:PHHargrove_at_[hidden]>
>> Future Technologies Group
>> HPC Research Department Tel: +1-510-495-2352
>> Lawrence Berkeley National Laboratory Fax: +1-510-486-6900
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden] <mailto:devel_at_[hidden]>
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900