Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 1.4.5rc4 is out
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-01-31 15:51:13


On Jan 31, 2012, at 3:48 PM, Paul H. Hargrove wrote:

>> 2) Must --disable-io-romio on OpenBSD
>
> Nobody has yet told me to shutup about that one, so I mention it here for completeness.
> Having looked only briefly at the failure, I see that it is in ROMIO's equivalent of opal_path_nfs().
> So, there could be logic in opal/util/path.c to fix ROMIO for OpenBSD.
> Of course, that is assuming no errors then pop up later in the build.

Oops -- Brad was supposed to put that in README, too.

We're not excited about making changes to such an old version of ROMIO.

1.5.x is about to transition to v1.6, meaning that it will replace the 1.4 series. So we want to have a "near perfect" 1.4.5 release, but that doesn't necessarily mean making a heroic effort to update/fix some old software packages when a newer, stable version (that hopefully fixes the problem!) is around the corner.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/