Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 1.4.5rc2 test results
From: Paul H. Hargrove (PHHargrove_at_[hidden])
Date: 2012-01-19 17:02:06


I neglected to mention that all FreeBSD and OpenBSD tests were conducted
using GNU Make.
If I use /usr/bin/make (BSD make), then I encounter the same problem I
reported against ompi-1.5.5rc1:
     https://svn.open-mpi.org/trac/ompi/ticket/2954

Note that there is a patch (against 1.5.5rc1) attached to that ticket
that may be sufficient to fix this.

Oddly, NetBSD doesn't display the problem. I don't know if there is
something different happening with respect to the atomics that simply
avoids the problem, or if NetBSD's version of Make may share the GNU
Make behavior with respect to VPATH.

-Paul

On 1/19/2012 1:33 PM, Paul H. Hargrove wrote:
>
> Here is a report on my findings with "configure && make all && make
> install && make check" with ompi-1.4.5rc2.
> All platforms built the "self", "sm" and "tcp" btls. I've noted where
> addition btl/mtl components were built.
>
> PASS with no special configure arguments (just --prefix and things
> like "CFLAGS=-m64" when appropriate).
> This means GNU compilers were used in all cases.
> linux/x86 [including gm1, gm2 and elan]
> linux/x86-64 [including gm2, elan, ofud, openib and psm]
> linux/ia64 (SGI Altix)
> linux/ppc32
> linux/ppc64
> macos-10.4/x86
> macos-10.4/ppc
> macos-10.5/x86
> macos-10.5/ppc
> macos-10.6/x86
> solaris-11(snv_151a)/amd64 [including ofud, openib and dapl]
> freebsd-6.3-RELEASE/amd64
> freebsd-7.2-RELEASE/amd64
> freebsd-8.2-RELEASE/amd64
> freebsd-8.2-RELEASE/i386
> netbsd-5.0.2/i386
> netbsd-5.1/amd64
> netbsd-5.1/i386
>
> PASS with addition of --disable-io-romio
> openbsd-5.0/amd64
> openbsd-5.0/i386
> This need do disable ROMIO is "known", having been reported against
> 1.4.5rc1 (see
> http://www.open-mpi.org/community/lists/devel/2011/12/10086.php ) as
> well as against 1.4.3rc1 in the past (see
> http://www.open-mpi.org/community/lists/devel/2010/08/8338.php ).
>
> FAIL
> macos-10.3/ppc
> Same problem as reported against 1.4.5rc1 in
> http://www.open-mpi.org/community/lists/devel/2011/12/10086.php
>
> I have additional Solaris platforms which I will report on later.
>
> -Paul
>

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900