Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] 1.5.5rc1 tested: VT check failures on *BSD (with patch).
From: Paul H. Hargrove (PHHargrove_at_[hidden])
Date: 2011-12-14 01:44:48


OK, Jeff probably wants to choke me for all these emails, but here comes
another...

I am now configuring my 5 BSD systems with "--without-hwloc
--disable-io-romio".
The systems (all using /usr/bin/gcc) are:

FreeBSD-8.2-RELEASE on amd64:
    gcc (GCC) 4.2.1 20070719 [FreeBSD]
FreeBSD-7.2-RELEASE on amd64:
    gcc (GCC) 4.2.1 20070719 [FreeBSD]
FreeBSD-6.3-RELEASE on amd64:
    gcc (GCC) 3.4.6 [FreeBSD] 20060305
NetBSD-5.1 on amd64:
    gcc (GCC) 4.1.3 20080704 prerelease (NetBSD nb2 20081120)
OpenBSD-5.0 on amd64:
    gcc (GCC) 4.2.1 20070719

Running "gmake check" terminates on ALL FIVE systems with:
> gmake[8]: Entering directory
> `/usr/home/phargrov/openmpi-1.5.5rc1/BUILD-nohwloc/ompi/contrib/vt/vt/extlib/otf/tools/otfprofile'
> CXX otfprofile-clustering.o
> ../../../../../../../../../ompi/contrib/vt/vt/extlib/otf/tools/otfprofile/clustering.cpp:
> In function 'bool ProcessClustering(AllData&)':
> ../../../../../../../../../ompi/contrib/vt/vt/extlib/otf/tools/otfprofile/clustering.cpp:138:
> error: 'WEXITSTATUS' was not declared in this scope
> gmake[8]: *** [otfprofile-clustering.o] Error 1

As I mentioned in another message, 1.5.4 passed "gmake all install
check" on at least the FreeBSD-8.2 system when configured with just
"--disable-io-romio", making this a REGRESSION.

Applying the 2-line patch below resolved the problem on ALL FIVE systems.

-Paul

-cut here-
---
openmpi-1.5.5rc1-orig/ompi/contrib/vt/vt/extlib/otf/tools/otfprofile/clustering.cpp
2011-12-13 22:24:10.000000000 -0800
+++
openmpi-1.5.5rc1/ompi/contrib/vt/vt/extlib/otf/tools/otfprofile/clustering.cpp
2011-12-13 22:25:24.000000000 -0800
@@ -10,6 +10,8 @@
  #include <stdio.h>
  #include <stdlib.h>
  #include <string.h>
+#include <sys/types.h>
+#include <sys/wait.h>

  #include "OTF_Platform.h"

-cut here-

On 12/13/2011 8:36 PM, Jeff Squyres wrote:
> In the usual place:
>
> http://www.open-mpi.org/software/ompi/v1.5/
>
> Please test! I would really like to get this out by the end of the week.
>
> Two issues *might* still be considered for this release:
>
> Putting back the openib minor fixes
> https://svn.open-mpi.org/trac/ompi/ticket/2930
>
> Making the "your SM file is on an NFS!" warning disable-able
> (this is the v1.4 ticket)
> https://svn.open-mpi.org/trac/ompi/ticket/2937
>
> They would both need to be fixed in the *immediate future* to be considered.
>

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900