Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] r25470 (hwloc CMR) breaks v1.5
From: TERRY DONTJE (terry.dontje_at_[hidden])
Date: 2011-11-16 06:32:07


On 11/15/2011 10:16 PM, Jeff Squyres wrote:
> On Nov 14, 2011, at 10:17 PM, Eugene Loh wrote:
>
>> I tried building v1.5. r25469 builds for me, r25470 does not. This is Friday's hwloc putback of CMR 2866. I'm on Solaris11/x86. The problem is basically:
> Doh!
>
>> Making all in tools/ompi_info
>> CC ompi_info.o
>> "../../../opal/include/opal/sys/ia32/atomic.h", line 173: warning: parameter in inline asm statement unused: %2
> Have these warnings always been there for you? r25470 should not have changed any of the assembly stuff.
>
Yes. You can ignore these warnings they aren't the droids you are
looking for.
>> CCLD ompi_info
>> Undefined first referenced
>> symbol in file
>> opal_hwloc122_hwloc_bitmap_dup components.o
>> opal_hwloc122_hwloc_bitmap_weight components.o
>> ld: fatal: symbol referencing errors. No output written to .libs/ompi_info
> I do notice some minor differences between ompi-trunk/ompi-1.5 in the opal/mca/hwloc/hwloc122ompi/hwloc trees.
>
> Terry: did you add some stuff to the trunk in topology-solaris-chiptype.c, for example?
>
Yes, but they have nothing to do with the undefined symbols above.
> If so, the right solution might just be to copy from trunk/opal/mca/hwloc/hwloc122ompi/hwloc/* to ompi-1.5/opal/mca/hwloc/hwloc122ompi/hwloc/.
>

-- 
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.781.442.2631
Oracle *- Performance Technologies*
95 Network Drive, Burlington, MA 01803
Email terry.dontje_at_[hidden] <mailto:terry.dontje_at_[hidden]>



picture