Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [BUG?] OpenMPI with openib on SPARC64: Signal: Bus error (10)
From: TERRY DONTJE (terry.dontje_at_[hidden])
Date: 2011-11-23 13:52:11


On 11/23/2011 1:45 PM, Lukas Razik wrote:
> TERRY DONTJE<terry.dontje_at_[hidden]> wrote
>
>> Can you build OMPI as a 32 bit library and see if that works any better?
> So you mean I shall leave the whole OFED stack as 64 bit and build only openmpi as 32 bit?
I believe the OFED user libraries will need to be 32 bit also or the 32
bit MPI libraries will not be able to use them.
> How must I configure openmpi that it'll be definitely built as 32bit?
You need to change the CFLAGS, CXXFLAGS, FFLAGS and FCFLAGS in the
configure line such that you replace "-m64" with "-m32" or just "-m32"
if "-m64" is not there?
> Regards,
> Lukas
>

-- 
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.781.442.2631
Oracle *- Performance Technologies*
95 Network Drive, Burlington, MA 01803
Email terry.dontje_at_[hidden] <mailto:terry.dontje_at_[hidden]>



picture