Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] yyunput warnings
From: Boehm, Swen (bohms_at_[hidden])
Date: 2011-10-06 15:25:43


I don't know if it works with 2.5.4 for sure but I have seen lexer files that handle differences between 2.5.4 and 2.5.33 and they don't handle %option noun put differently. I would assume it will work. Maybe someone still using 2.5.4 can validate this.

-- Swen

On Oct 6, 2011, at 2:59 PM, Jeff Squyres wrote:

> Nifty -- I had no idea that %unput existed. Do you know how far back it works in flex versions? We currently say on the web site that developers need at least flex 2.5.4 to build. Will using an %unput (say, in trunk and v1.5) require a new minimum flex version?
>
>
> On Oct 6, 2011, at 2:55 PM, Boehm, Swen wrote:
>
>> Fwiw I created a patch to get rid of the following warnings:
>>
>> keyval_lex.c:1251: warning: 'yyunput' defined but not used
>> show_help_lex.c:1182: warning: 'yyunput' defined but not used
>> carto_file_lex.c:1256: warning: 'yyunput' defined but not used
>> util/hostfile/hostfile_lex.c:1665: warning: 'yyunput' defined but not used
>> rmaps_rank_file_lex.c:1408: warning: 'yyunput' defined but not used
>>
>> let me know what you think.
>>
>> -- Swen
>>
>> <ompi_yyunput.diff>_______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> hxxp://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> hxxp://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> hxxp://www.open-mpi.org/mailman/listinfo.cgi/devel
>