Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [OMPI svn-full] svn:open-mpi r25093
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-08-26 19:47:52


Strange -- I don't see where ORTE_ENABLE_EPOCH is defined at all, other than some warnings about it not being defined in autom4te.cache (which is weird in itself -- it means that things in configure were complaining that it wasn't defined; but the wording might imply that it was looking for an AM_CONDITIONAL by that name...? I'm not sure):

-----
[16:45] svbu-mpi:~/svn/ompi4 % grep -r ORTE_ENABLE_EPOCH * | grep -v /.svn/ | grep define
autom4te.cache/output.1: as_fn_error "conditional \"ORTE_ENABLE_EPOCH\" was never defined.
autom4te.cache/output.0: as_fn_error "conditional \"ORTE_ENABLE_EPOCH\" was never defined.
autom4te.cache/output.2: as_fn_error "conditional \"ORTE_ENABLE_EPOCH\" was never defined.
configure: as_fn_error "conditional \"ORTE_ENABLE_EPOCH\" was never defined.
[16:45] svbu-mpi:~/svn/ompi4 %
-----

Is there a new file that accidentally didn't get committed, perchance?

On Aug 26, 2011, at 7:38 PM, Jeff Squyres wrote:

> Wesley --
>
> I'm getting a bazillion "warning: "ORTE_ENABLE_EPOCH" is not defined" warnings. By "bazillion", I mean:
>
> % grep ORTE_ENABLE_EPOCH make.out | grep warning | wc -l
> 8695
> %
>
> Here's my configure statement on both OS X and Linux:
>
> ./configure --prefix=/tmp/bogus --disable-mpi-f77 --disable-vt --disable-io-romio --enable-mpirun-prefix-by-default
>
> Please fix...
>
>
>
> On Aug 26, 2011, at 6:18 PM, Wesley Bland wrote:
>
>> The epoch and resilient rote code is now macro'd away. To enable use
>>
>> --enable-resilient-orte
>>
>> which defines:
>>
>> ORTE_ENABLE_EPOCH
>> ORTE_RESIL_ORTE
>>
>> --
>>
>> Wesley
>>
>> On Aug 26, 2011, at 6:16 PM, wbland_at_[hidden] wrote:
>>
>>> Author: wbland
>>> Date: 2011-08-26 18:16:14 EDT (Fri, 26 Aug 2011)
>>> New Revision: 25093
>>> URL: https://svn.open-mpi.org/trac/ompi/changeset/25093
>>>
>>> Log:
>>> By popular demand the epoch code is now disabled by default.
>>>
>>> To enable the epochs and the resilient orte code, use the configure flag:
>>>
>>> --enable-resilient-orte
>>>
>>> This will define both:
>>>
>>> ORTE_ENABLE_EPOCH
>>> ORTE_RESIL_ORTE

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/