Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Trunk problem: VT breakage
From: Yevgeny Kliteynik (kliteyn_at_[hidden])
Date: 2011-06-30 10:18:12


Same here:

  .......
  CXX vtfilter-vt_filter.o
  CXX vtfilter-vt_filter_common.o
  CXX vtfilter-vt_filter_gen.o
  CXX vtfilter-vt_filter_trc.o
  CXX vtfilter-vt_filter_trc_hdlr.o
  CXX vtfilter-vt_filterc.o
make[7]: *** No rule to make target `vt_filthandler.cc', needed by `vtfilter-vt_filthandler.o'. Stop.

Note that this happens only on 'svn up' on existing repository.
When doing fresh 'svn co && autogen && configure && make', everything works fine.

-- YK

On 30-Jun-11 4:37 PM, Jeff Squyres wrote:
> FWIW, I get the same error as Ralph. I'm on my laptop battery atm, so I don't want to do a fresh checkout/build. This is from an "Svn up" with a fresh automake/configure:
>
> [9:32] rtp-jsquyres-8714:~/svn/ompi/ompi/contrib/vt/vt/tools/vtfilter % make
> Making all in .
> make[1]: *** No rule to make target `vt_filthandler.cc', needed by `vtfilter-vt_filthandler.o'. Stop.
> make: *** [all-recursive] Error 1
> [9:32] rtp-jsquyres-8714:~/svn/ompi/ompi/contrib/vt/vt/tools/vtfilter %
>
> Is there some file that we need to delete to make the tree build?
>
> Is the problem in the corresponding .deps file?
>
>
> On Jun 30, 2011, at 9:05 AM, Matthias Jurenz wrote:
>
>> It seems to me that anything during your last update went wrong. Since r24803
>> the source file 'vt_filthandler.cc' is moved to the subdirectory 'old', so
>> actually if the source file doesn't exist the error message should be:
>>
>> No rule to make target `old/vt_filthandler.cc', needed by `vtfilter-
>> vt_filthandler.o'. Stop.
>>
>> (I just tested it by removing the source file by hand)
>>
>> Does the error occur also with a completely new checkout of the trunk?
>>
>> Matthias
>>
>> On Thursday 30 June 2011 03:01:10 Ralph Castain wrote:
>>> It appears I cannot build the trunk on Mac - I hit this issue when I
>>> updated from the trunk and rebuilt from autogen this evening:
>>>
>>> make[7]: *** No rule to make target `vt_filthandler.cc', needed by
>>> `vtfilter-vt_filthandler.o'. Stop.
>>>
>>> Vanilla configure - I didn't turn VT off like I usually do.
>>>
>>> Any help would be appreciated.
>>>
>>>
>>> _______________________________________________
>>> devel mailing list
>>> devel_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>> --
>> Matthias Jurenz
>>
>> Technische Universität Dresden
>> Center for Information Services and High Performance Computing (ZIH)
>> 01062 Dresden, Germany
>> Phone: +49 (351) 463-31945
>> Fax: +49 (351) 463-37773
>> E-Mail: matthias.jurenz_at_[hidden]
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>