Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Compiling problem in trunk?
From: Xin He (xin.i.he_at_[hidden])
Date: 2011-06-28 05:25:05


Strangely, as I re-downloaded everything and built from scratch again,
there was no error this time.

On 06/27/2011 04:32 PM, Jeff Squyres wrote:
> Actually, can you send all the information listed here:
>
> http://www.open-mpi.org/community/help/
>
>
> On Jun 27, 2011, at 10:04 AM, Xin He wrote:
>
>> Hi,
>>
>> the appendix is my config.log. Hope it will be helpful.
>>
>> Regards,
>> Xin
>>
>> On 06/27/2011 03:22 PM, Josh Hursey wrote:
>>> I tried a fresh checkout of the trunk this morning (r24823) and could
>>> not reproduce with that configure string on a Linux
>>> 2.6.18-238.12.1.el5 x86_64 machine.
>>>
>>> Can you send a zip'ed up copy of your config.log? That may help us
>>> highlight any other environment differences.
>>>
>>> -- Josh
>>>
>>>
>>> On Mon, Jun 27, 2011 at 5:01 AM, Xin He<xin.i.he_at_[hidden]> wrote:
>>>> Hi,
>>>>
>>>> I even tried re-downloading the whole project and did all things. First
>>>> autogen, then ./configure --disable-mpi-f90 --disable-mpi-f77
>>>> --disable-mpi-cxx --disable-vt --disable-io-romio --prefix=/usr
>>>> --enable-heterogeneous. It was during "make" those messages displayed.
>>>>
>>>> I'm using Ubuntu 64bit.
>>>>
>>>> /Xin
>>>>
>>>> On 06/23/2011 05:49 PM, Jeff Squyres wrote:
>>>>> Xin --
>>>>>
>>>>> Can you provide more details on exactly what part of the build is failing?
>>>>> None of the rest of us are seeing the problem.
>>>>>
>>>>> When you svn up'ed, did you re-run autogen.pl / configure?
>>>>>
>>>>>
>>>>>
>>>>> On Jun 23, 2011, at 9:04 AM, Xin He wrote:
>>>>>
>>>>>> Thanks for the tips about configuration. Yet the build still failed.
>>>>>> Anyway, I managed to roll back to an earlier version and successfully
>>>>>> installed :)
>>>>>>
>>>>>> /Xin
>>>>>>
>>>>>> On 06/23/2011 01:26 PM, Jeff Squyres wrote:
>>>>>>> I don't believe we have changed anything in the trunk w.r.t. the Fortran
>>>>>>> 90 stuff (there's stuff off in a branch waiting to come in, but I don't
>>>>>>> think it has come in).
>>>>>>>
>>>>>>> Since you're primarily working on a new BTL, you might want to speed up
>>>>>>> your configure/build process by disabling Fortran and other optional stuff.
>>>>>>> Try:
>>>>>>>
>>>>>>> ./configure --disable-mpi-f90 --disable-mpi-f77 --disable-mpi-cxx
>>>>>>> --disable-vt --disable-io-romio ...
>>>>>>>
>>>>>>> That should speed things up a bit, and also avoid whatever this Fortran
>>>>>>> problem is.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Jun 23, 2011, at 7:23 AM, Xin He wrote:
>>>>>>>
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> as I compiled the sources from "trunk". I got these error messages when
>>>>>>>> doing make:
>>>>>>>>
>>>>>>>> [blablabla...]
>>>>>>>> make all-am
>>>>>>>> make[3]: Entering directory `/home/ehhexxn/git/ompi/ompi/include'
>>>>>>>> FC mpif90-ext.lo
>>>>>>>> libtool: compile: unrecognized option `-c'
>>>>>>>> libtool: compile: Try `libtool --help' for more information.
>>>>>>>> make[3]: *** [mpif90-ext.lo] Error 1
>>>>>>>> make[3]: Leaving directory `/home/ehhexxn/git/ompi/ompi/include'
>>>>>>>> make[2]: *** [all] Error 2
>>>>>>>> make[2]: Leaving directory `/home/ehhexxn/git/ompi/ompi/include'
>>>>>>>> make[1]: *** [all-recursive] Error 1
>>>>>>>> make[1]: Leaving directory `/home/ehhexxn/git/ompi/ompi'
>>>>>>>> make: *** [all-recursive] Error 1
>>>>>>>>
>>>>>>>>
>>>>>>>> I was able to compile an earlier version of trunk.
>>>>>>>>
>>>>>>>> Best regards,
>>>>>>>> Xin
>>>>>>>> _______________________________________________
>>>>>>>> devel mailing list
>>>>>>>> devel_at_[hidden]
>>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>>>> _______________________________________________
>>>>>> devel mailing list
>>>>>> devel_at_[hidden]
>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>> _______________________________________________
>>>> devel mailing list
>>>> devel_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>>
>>>>
>>>
>>
>>
>> *****************************************************************************
>> ** **
>> ** WARNING: This email contains an attachment of a very suspicious type. **
>> ** You are urged NOT to open this attachment unless you are absolutely **
>> ** sure it is legitimate. Opening this attachment may cause irreparable **
>> ** damage to your computer and your files. If you have any questions **
>> ** about the validity of this message, PLEASE SEEK HELP BEFORE OPENING IT. **
>> ** **
>> ** This warning was added by the IU Computer Science Dept. mail scanner. **
>> *****************************************************************************
>>
>>
>> <config.log.zip>_______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>