Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Compiling problem in trunk?
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-06-23 09:44:34


FWIW: I haven't seen this problem on Mac or Linux since your commit, but I build with fortran disabled. Still, he claims to be seeing it even with disable-fortran, so I should have seen it too....

On Jun 23, 2011, at 7:38 AM, Josh Hursey wrote:

> Yea that is where the problem is showing up, but I'm not sure why.
>
> Is this a 'fresh' SVN checkout of the Open MPI trunk (so it has never
> been used to build Open MPI before)? What configure options are you
> passing to Open MPI?
>
> I'm wondering if this is due to updating an existing branch and
> something getting out of whack in the autogen/configure setup.
>
> If this happens with a fresh checkout of the Open MPI, then I can try
> to dig in a bit more - but I have not seen this in any of the test
> builds so far.
>
> -- Josh
>
>
> On Thu, Jun 23, 2011 at 9:31 AM, Ralph Castain <rhc_at_[hidden]> wrote:
>> Looks like the commit that brought in Fortran support for the MPI extensions has a problem?
>>
>>
>> On Jun 23, 2011, at 7:04 AM, Xin He wrote:
>>
>>> Thanks for the tips about configuration. Yet the build still failed. Anyway, I managed to roll back to an earlier version and successfully installed :)
>>>
>>> /Xin
>>>
>>> On 06/23/2011 01:26 PM, Jeff Squyres wrote:
>>>> I don't believe we have changed anything in the trunk w.r.t. the Fortran 90 stuff (there's stuff off in a branch waiting to come in, but I don't think it has come in).
>>>>
>>>> Since you're primarily working on a new BTL, you might want to speed up your configure/build process by disabling Fortran and other optional stuff. Try:
>>>>
>>>> ./configure --disable-mpi-f90 --disable-mpi-f77 --disable-mpi-cxx --disable-vt --disable-io-romio ...
>>>>
>>>> That should speed things up a bit, and also avoid whatever this Fortran problem is.
>>>>
>>>>
>>>>
>>>> On Jun 23, 2011, at 7:23 AM, Xin He wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> as I compiled the sources from "trunk". I got these error messages when doing make:
>>>>>
>>>>> [blablabla...]
>>>>> make all-am
>>>>> make[3]: Entering directory `/home/ehhexxn/git/ompi/ompi/include'
>>>>> FC mpif90-ext.lo
>>>>> libtool: compile: unrecognized option `-c'
>>>>> libtool: compile: Try `libtool --help' for more information.
>>>>> make[3]: *** [mpif90-ext.lo] Error 1
>>>>> make[3]: Leaving directory `/home/ehhexxn/git/ompi/ompi/include'
>>>>> make[2]: *** [all] Error 2
>>>>> make[2]: Leaving directory `/home/ehhexxn/git/ompi/ompi/include'
>>>>> make[1]: *** [all-recursive] Error 1
>>>>> make[1]: Leaving directory `/home/ehhexxn/git/ompi/ompi'
>>>>> make: *** [all-recursive] Error 1
>>>>>
>>>>>
>>>>> I was able to compile an earlier version of trunk.
>>>>>
>>>>> Best regards,
>>>>> Xin
>>>>> _______________________________________________
>>>>> devel mailing list
>>>>> devel_at_[hidden]
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>>
>>>
>>> _______________________________________________
>>> devel mailing list
>>> devel_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>>
>
>
>
> --
> Joshua Hursey
> Postdoctoral Research Associate
> Oak Ridge National Laboratory
> http://users.nccs.gov/~jjhursey
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel