Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Compiling problem in trunk?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-06-23 07:26:38


I don't believe we have changed anything in the trunk w.r.t. the Fortran 90 stuff (there's stuff off in a branch waiting to come in, but I don't think it has come in).

Since you're primarily working on a new BTL, you might want to speed up your configure/build process by disabling Fortran and other optional stuff. Try:

    ./configure --disable-mpi-f90 --disable-mpi-f77 --disable-mpi-cxx --disable-vt --disable-io-romio ...

That should speed things up a bit, and also avoid whatever this Fortran problem is.

On Jun 23, 2011, at 7:23 AM, Xin He wrote:

> Hi,
>
> as I compiled the sources from "trunk". I got these error messages when doing make:
>
> [blablabla...]
> make all-am
> make[3]: Entering directory `/home/ehhexxn/git/ompi/ompi/include'
> FC mpif90-ext.lo
> libtool: compile: unrecognized option `-c'
> libtool: compile: Try `libtool --help' for more information.
> make[3]: *** [mpif90-ext.lo] Error 1
> make[3]: Leaving directory `/home/ehhexxn/git/ompi/ompi/include'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/home/ehhexxn/git/ompi/ompi/include'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/ehhexxn/git/ompi/ompi'
> make: *** [all-recursive] Error 1
>
>
> I was able to compile an earlier version of trunk.
>
> Best regards,
> Xin
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/