Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 1.4.4rc2 is up
From: Larry Baker (baker_at_[hidden])
Date: 2011-05-18 14:08:03


Jeff,

> Is this guaranteed to work for all versions of the PGI compiler?
> I.e., does "pgCC -V" always return something in the form of (digit)+
> \. ?

I don't know, but I think so. See your Nov 2009 discussion of this
bug and Ralf Wildenhues' libtool.m4 patches at http://www.open-mpi.org/community/lists/users/2009/11/11277.php
.

Larry Baker
US Geological Survey
650-329-5608
baker_at_[hidden]

On 18 May 2011, at 5:50 AM, Jeff Squyres wrote:

> (adding libtool-patches_at_[hidden])
>
> Is this guaranteed to work for all versions of the PGI compiler?
> I.e., does "pgCC -V" always return something in the form of (digit)+
> \. ?
>
>
> On May 17, 2011, at 8:52 PM, Larry Baker wrote:
>
>> This bug applies to OpenMPI 1.4.x and 1.5.x.
>>
>> The libtool.m4 in config and opal/libltdl/m4 do not properly
>> determine the version of the PGI compiler, which then set the wrong
>> compile/link options. They interpret V11.4 (version no. begins
>> with a 1), for example, as being a V1 to V5 compiler. There is a
>> missing period in the pattern, so that only text like 1.x through
>> 5.x matches.
>>
>> Here's the diff -u from OpenMPI 1.4.3 (same code, same bug):
>>
>>> [root_at_hydra openmpi-1.4.3]# diff -u config/libtool.m4{.original,}
>>> --- config/libtool.m4.original 2010-10-05 15:45:44.000000000 -0700
>>> +++ config/libtool.m4 2011-05-17 15:32:31.000000000 -0700
>>> @@ -5896,7 +5896,7 @@
>>> pgCC* | pgcpp*)
>>> # Portland Group C++ compiler
>>> case `$CC -V` in
>>> - *pgCC\ [[1-5]]* | *pgcpp\ [[1-5]]*)
>>> + *pgCC\ [[1-5]].* | *pgcpp\ [[1-5]].*)
>>> _LT_TAGVAR(prelink_cmds, $1)='tpldir=Template.dir~
>>> rm -rf $tpldir~
>>> $CC --prelink_objects --instantiation_dir $tpldir $objs $libobjs
>>> $compile_deplibs~
>>
>> Larry Baker
>> US Geological Survey
>> 650-329-5608
>> baker_at_[hidden]
>>
>> On 5 May 2011, at 7:15 AM, Jeff Squyres wrote:
>>
>>> Fixed the ROMIO attribute problem properly this time -- it's in
>>> the usual place:
>>>
>>> http://www.open-mpi.org/software/ompi/v1.4/
>>>
>>> --
>>> Jeff Squyres
>>> jsquyres_at_[hidden]
>>> For corporate legal information go to:
>>> http://www.cisco.com/web/about/doing_business/legal/cri/
>>>
>>>
>>> _______________________________________________
>>> devel mailing list
>>> devel_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel