Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] ompi_mpi_init: orte_init failed
From: Larry Baker (baker_at_[hidden])
Date: 2011-01-20 18:34:50


Francis,

I cannot address your situation specifically, but I can tell you from
experience that you must pay close attention to the version of Mac OS
X for 32-bit/64-bit compiling. gcc/gfortran defaults to 32-bit on OS
X 10.5. I am told they default to 64-bit on OS X 10.6. Thus, to
compile and link with the proper 64-bit libraries, you may have to
specify -m64 at every step: when creating the OpenMPI library, when
compiling your application, and when linking your application
(presumably, the last two steps are done by an OpenMPI wrapper script
for you).

On my (desktop) OS X 10.5 Mac, I used the following commands to patch
(using my own patch script) and make OpenMPI 1.4.2:

> # Patch OpenMPI 1.4.2
> tar -xjf openmpi-1.4.2.tar.bz2
> source patch-openmpi-1.4.2.sh
>
> # Configure OpenMPI 1.4.2 for GNU compilers
> cd openmpi-1.4.2
> ./configure >configure.log 2>&1 \
> --prefix=$HOME/Desktop/Software/OpenMPI/gnu \
> CC="gcc -m64" \
> CFLAGS="-g -fast" \
> CXX="g++ -m64" \
> CXXFLAGS="-g -fast" \
> FC="gfortran -m64" \
> FCFLAGS="-g -fast" \
> F77="gfortran -m64" \
> FFLAGS="-g -fast"
>
> # Make the library
> make >make.log 2>&1
>
> # Validate the library
> make check >check.log 2>&1

Then, I used the following commands to install it:

> # Install OpenMPI 1.4.2
> cd openmpi-1.4.2
> make install >install.log 2>&1

Maybe the first thing you could try is to run make check on your
laptop. I don't have a laptop to try to replicate your failure.

Larry Baker
US Geological Survey
650-329-5608
baker_at_[hidden]

On Jan 20, 2011, at 2:00 PM, Francis Poulin wrote:

> Hello,
>
> I'm trying to build OpenMPI with fortran on my Mac OS machines using
> gfortran. I'm using the 64-bit option and trying to install 1.4.2.
> It seems to build ok and when I compile and run simple programs it
> works. When I try a more complicated case it works on my desktop
> but not my laptop. The error that I get is shown below. The fact
> that it works on my desktop shows me there's a problem with my build
> on my laptop.
>
> Any ideas where I can look to fix it?
>
> Thanks,
> Francis
>
> [[INVALID],INVALID] ORTE_ERROR_LOG: Not found in file runtime/
> orte_init.c at line 125
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel
> process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ess_base_select failed
> --> Returned value Not found (-13) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> It looks like MPI_INIT failed for some reason; your parallel process
> is
> likely to abort. There are many reasons that a parallel process can
> fail during MPI_INIT; some of which are due to configuration or
> environment
> problems. This failure appears to be an internal failure; here's some
> additional information (which may only be relevant to an Open MPI
> developer):
>
> ompi_mpi_init: orte_init failed
> --> Returned "Not found" (-13) instead of "Success" (0)
> --------------------------------------------------------------------------
> *** The MPI_Init() function was called before MPI_INIT was invoked.
> *** This is disallowed by the MPI standard.
> *** Your MPI job will now abort.
>
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel