Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] debugger attach broken in trunk
From: Ralph Castain (rhc_at_[hidden])
Date: 2010-10-14 19:28:08


Yeah, I heard about it a couple of weeks ago. On the "to-do" list for the future.

On Oct 14, 2010, at 4:20 PM, Ashley Pittman wrote:

>
> It's been reported to me that using current SVN head debugger attach support is broken, both the MPIR interface and the orte-ps command are returning no data for the hostnames and process identifiers of launched jobs.
>
> The v1.5 download is fine, I've checked that on both counts but a checkout of the trunk exhibits the problem.
>
> ashley_at_cloud1:~/code/padb-read-only/src$ orte-ps
>
> Information from mpirun [59875,0]
> ---------------------------------
>
> JobID | State | Slots | Num Procs |
> ------------------------------------------
> [59875,1] | Running | 1 | 0 |
> Process Name | ORTE Name | Local Rank | PID | Node | State |
> ------------------------------------------------------
>
> $ gdb -p <pidof mpirun>
> (gdb) p MPIR_proctable
> $1 = (struct MPIR_PROCDESC *) 0x0
> (gdb) p MPIR_proctable_size
> $2 = 0
> (gdb) p MPIR_PROCDESC
>
> ashley_at_cloud1:~/code/padb-read-only/src$ ./padb -Ormgr=mpirun -a --proc-summary -Odebug
>
> Ashley.
>
> --
>
> Ashley Pittman, Bath, UK.
>
> Padb - A parallel job inspection tool for cluster computing
> http://padb.pittman.org.uk
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel