Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Autogen.pl, romio and autoconf 2.66
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-09-28 17:55:35


On Sep 28, 2010, at 5:30 PM, Aurélien Bouteiller wrote:

> Hi there,
>
> has anybody tried to compile ompi trunk with autoconf 2.66 ? It fails when configuring romio with the following error:
> === Processing subdir: /nics/c/home/bouteill/ompi/trunk/ompi/mca/io/romio/romio
> --- Found configure.in|ac; running autoreconf...
> autoreconf: Entering directory `.'
> autoreconf: configure.in: not using Gettext
> autoreconf: running: aclocal --force
> configure.in:2127: warning: macro `AM_PROG_LIBTOOL' not found in library

This looks like Libtool or Automake isn't installed properly...?

> configure.in:791: error: AC_CHECK_SIZEOF: requires literal arguments
> ../../lib/autoconf/types.m4:765: AC_CHECK_SIZEOF is expanded from...
> configure.in:791: the top level
> autom4te: /sw/xt/autoconf/2.66/cnl2.2_gnu4.4.4/bin/m4 failed with exit status: 1
> aclocal: /sw/xt/autoconf/2.66/cnl2.2_gnu4.4.4/bin/autom4te failed with exit status: 1
> autoreconf: aclocal failed with exit status: 1
> Command failed: autoreconf -ivf
>
> Should I demote my autoconf to 2.65 ?
>
> Thanks,
> Aurelien
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/