Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] update configury for Autoconf 2.68
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-09-24 09:26:46


On Sep 23, 2010, at 2:15 PM, Ralf Wildenhues wrote:

>> Is the silent-rules clause in AM_INIT_AUTOMAKE exactly equivalent to
>> calling AM_SILENT_RULES?
>
> Yes.

Weird -- when I do this:

Index: configure.ac
===================================================================
--- configure.ac (revision 23795)
+++ configure.ac (working copy)
@@ -82,11 +82,8 @@
 #
 # Init automake
 #
-AM_INIT_AUTOMAKE([foreign dist-bzip2 subdir-objects no-define 1.10 tar-ustar])
+AM_INIT_AUTOMAKE([foreign dist-bzip2 subdir-objects no-define 1.11 silent-rules tar-ustar])
 
-# If Automake supports silent rules, enable them.
-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-
 # Make configure depend on the VERSION file, since it's used in AC_INIT
 AC_SUBST([CONFIGURE_DEPENDENCIES], ['$(top_srcdir)/VERSION'])
 
I do not get silent rules behavior -- I still get the old verbose behavior. This is with:

-----
[9:23] rtp-jsquyres-8717:~/svn/ompi % automake --version | head -1
automake (GNU automake) 1.11.1
[9:23] rtp-jsquyres-8717:~/svn/ompi % libtool --version | head -1
libtool (GNU libtool) 2.2.10
[9:23] rtp-jsquyres-8717:~/svn/ompi % autoconf --version | head -1
autoconf (GNU Autoconf) 2.67
-----

Specifically, I only seem to get silent rules behavior if I AM_SILENT_RULES([yes]). Weird. I guess I'll remove the m4_ifdef but still leave the AM_SILENT_RULES([yes]).

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/